SP16 Conversion Services not updating?

New Contributor

We have an on-premise Sharepoint 2016 server with the latest patches, shows up as version 16.0.5149.1000 on the patch status page, but the files under C:\Program Files\Microsoft Office Servers\16.0\webservices\conversionservices\ don't seem to get upgraded. For example, sword.dll is still on version 16.0.4927.1000, which is vulnerable to some attacks.

 

I've attached a screenshot of Windows Explorer showing more of the files and their version numbers, date format in the third column is DD.MM.YYYY Has anyone here seen something like this?

4 Replies
Sorry, no suggestions but I have the same problem. Did you manage to find a solution?

Not yet, I'm planning to check if there are any log files from the upgrade process that help with troubleshooting and, if not, to reinstall Sharepoint.

I couldn't find anything helpful in the logs. I'm lucky this is just a standalone dev server so I've just renamed the file so it passes our security scan. I'll un-rename it when next month's CUs come out and hopefully it'll get patched then.
Just tried applying the June 2021 CU hoping it would update that file - no luck. But found this suggestion which worked: https://docs.microsoft.com/answers/answers/426599/view.html

Rename and repair! Hope this works for you too.