SOLVED

SP Online Discussion Board Wrong Time Zone

%3CLINGO-SUB%20id%3D%22lingo-sub-1353321%22%20slang%3D%22en-US%22%3ESP%20Online%20Discussion%20Board%20Wrong%20Time%20Zone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1353321%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20searched%20every%20crevice%20of%20the%20internet%20and%20cannot%20find%20a%20solution%20to%20my%20issue%20with%20discussion%20board%20timestamps%20on%20SharePoint%20online%3B%20can%20someone%26nbsp%3B%3CEM%3E%3CSTRONG%3Eplease%3C%2FSTRONG%3E%3C%2FEM%3E%3CEM%3E%26nbsp%3B%3C%2FEM%3Ehelp%20me!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20issue%3A%20When%20a%20user%20creates%20a%20post%20in%20the%20discussion%20board%2C%20it%20lists%20the%20post%20name%20and%20%22created%22%20time%20accurately.%20However%2C%20when%20you%20click%20the%20post%20name%20to%20view%20the%20discussion%2C%20all%20listed%20times%20are%207%20hours%20earlier%20than%20the%20actual%20time.%20Here%20are%20screenshots%20of%20this%20issue%20in%20action%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ETest%20Post%20is%20created%20with%20a%204%3A26%20PM%20timestamp%20(Pacific%20Standard%20Time)%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22ThomasShaw_0-1588350634420.png%22%20style%3D%22width%3A%20617px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F188225i4E07E83770A05EE7%2Fimage-dimensions%2F617x273%3Fv%3D1.0%22%20width%3D%22617%22%20height%3D%22273%22%20title%3D%22ThomasShaw_0-1588350634420.png%22%20alt%3D%22ThomasShaw_0-1588350634420.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3ETest%20Post%20thread%20shows%209%3A26%20AM%20timestamp.%20Note%20the%20tool-tip%20lists%20the%20correct%2024-hour%20timestamp.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22ThomasShaw_1-1588350704466.png%22%20style%3D%22width%3A%20584px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F188227iD234F5C2EC520136%2Fimage-dimensions%2F584x224%3Fv%3D1.0%22%20width%3D%22584%22%20height%3D%22224%22%20title%3D%22ThomasShaw_1-1588350704466.png%22%20alt%3D%22ThomasShaw_1-1588350704466.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFrom%20all%20the%20forums%20I've%20read%20through%20there%20were%20two%20obvious%20placed%20to%20check%3B%20personal%20regional%20settings%20in%20Delve%2C%20and%20administrator%20regional%20settings%20for%20the%20site.%20The%20admin%20settings%20are%20configured%20for%20Pacific%20Standard%20Time%20(as%20you%20can%20see%20from%20the%20example%20below)%20and%20my%20Delve%20account%20has%20been%20set%20to%20use%20those%20settings%20configured%20by%20the%20administrator%20(me).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESharePoint%20site%20settings%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22ThomasShaw_2-1588350916659.png%22%20style%3D%22width%3A%20687px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F188229i36273924D7326AC3%2Fimage-dimensions%2F687x515%3Fv%3D1.0%22%20width%3D%22687%22%20height%3D%22515%22%20title%3D%22ThomasShaw_2-1588350916659.png%22%20alt%3D%22ThomasShaw_2-1588350916659.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EMy%20personal%20Delve%20settings%3A%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22ThomasShaw_3-1588350944220.png%22%20style%3D%22width%3A%20655px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F188231i1A9C6C3C6F7D97A4%2Fimage-dimensions%2F655x514%3Fv%3D1.0%22%20width%3D%22655%22%20height%3D%22514%22%20title%3D%22ThomasShaw_3-1588350944220.png%22%20alt%3D%22ThomasShaw_3-1588350944220.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20tried%20updating%20my%20Office%20365%20regional%20settings%20through%20PowerShell%2C%20confirming%20search%20schema%20for%20created%20and%20modified%20dates%2C%20I%20tried%20to%20manually%20adjust%20the%20%22Flat%22%20view%20for%20the%20post%20to%20format%20the%20create%20and%20modified%20columns%20but%20nothing%20works.%20We're%20trying%20to%20get%20a%20discussion%20board%20set%20up%20for%20parents%20coping%20with%20home-schooling%20during%20the%20COVID%20pandemic%2C%20and%20I%20can't%20put%20this%20discussion%20board%20into%20production%20if%20users%20are%20going%20to%20be%20asking%20me%20everyday%20why%20their%20post%20time%20is%20incorrect.%20Any%20help%20with%20this%20would%20be%20absolutely%20appreciated.%20Thank%20you!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1353321%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Ediscussion%20board%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Eposts%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Etime%20zone%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1353360%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20Online%20Discussion%20Board%20Wrong%20Time%20Zone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1353360%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F250949%22%20target%3D%22_blank%22%3E%40ThomasShaw%3C%2FA%3E%26nbsp%3BAs%20I%20posted%20this%20I%20questioned%20whether%20I%20actually%20did%20confirm%20the%20crawl%20properties%20for%20%22created%22%20so%20I%20checked%20and%20they%20weren't%20all%20mapped.%20In%20the%20image%20below%2C%20the%20highlighted%20properties%20were%20not%20mapped%20to%20anything%20so%20I%20added%20in%20Created%20and%20re-indexed%20the%20site%20for%20good%20measure.%20I'll%20post%20an%20update%20this%20afternoon.%20Hopefully%20by%20then%20something%20will%20change.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22ThomasShaw_0-1588352271010.png%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F188243i6F8709E520E36DD5%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22ThomasShaw_0-1588352271010.png%22%20alt%3D%22ThomasShaw_0-1588352271010.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1353936%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20Online%20Discussion%20Board%20Wrong%20Time%20Zone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1353936%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F250949%22%20target%3D%22_blank%22%3E%40ThomasShaw%3C%2FA%3E%26nbsp%3BAfter%205%20hours%20there's%20been%20no%20change%20to%20the%20way%20these%20dates%20are%20displayed.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1365406%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20Online%20Discussion%20Board%20Wrong%20Time%20Zone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1365406%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F250949%22%20target%3D%22_blank%22%3E%40ThomasShaw%3C%2FA%3E%26nbsp%3BWe%20are%20having%20exactly%20the%20same%20issue%20and%20opened%20a%20support%20ticket%20with%20no%20definite%20answers%20yet.%20I'll%20post%20an%20update%20here%20if%20we%20hear%20anything%20from%20them%20that%20can%20help%20solve%20this%20issue.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1389139%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20Online%20Discussion%20Board%20Wrong%20Time%20Zone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1389139%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F32134%22%20target%3D%22_blank%22%3E%40Mara%20Lanz%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F250949%22%20target%3D%22_blank%22%3E%40ThomasShaw%3C%2FA%3E%26nbsp%3B%3CBR%20%2F%3EHaving%20the%20same%20issue%20in%20my%20SP%20Online%20environment.%20Anxious%20to%20see%20if%20either%20of%20you%20have%20made%20progress.%20We%20are%20also%20logging%20a%20ticket%20with%20MS%2C%20so%20I'll%20share%20any%20new%20info%20here.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1429861%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20Online%20Discussion%20Board%20Wrong%20Time%20Zone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1429861%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F250949%22%20target%3D%22_blank%22%3E%40ThomasShaw%3C%2FA%3E%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F573420%22%20target%3D%22_blank%22%3E%40SharePointEmily%3C%2FA%3E%26nbsp%3B%20After%20a%20few%20weeks%20of%20troubleshooting%20MS%20was%20able%20to%20find%2C%20test%20and%20release%20a%20global%20solution.%20The%20fix%20already%20made%20it%20to%20our%20tenant%2C%20check%20again%2C%20hopefully%20it%20made%20it%20yours%20as%20well.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1436705%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20Online%20Discussion%20Board%20Wrong%20Time%20Zone%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1436705%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F32134%22%20target%3D%22_blank%22%3E%40Mara%20Lanz%3C%2FA%3E%26nbsp%3BI%20honestly%20thought%20I%20was%20alone%20so%20we%20just%20switched%20to%20Microsoft%20Teams%20for%20this%20specific%20case.%20I%20did%20however%20just%20create%20another%20discussion%20board%20and%20it%20looks%20like%20the%20fix%20was%20applied%20and%20works!!%20Thank%20you%20for%20going%20down%20that%20avenue%20and%20taking%20the%20time%20to%20reply%2C%20I%20really%20appreciate%20it.%20It's%20nice%20to%20know%20we%20have%20that%20functionality%20back.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

I have searched every crevice of the internet and cannot find a solution to my issue with discussion board timestamps on SharePoint online; can someone please help me!

 

The issue: When a user creates a post in the discussion board, it lists the post name and "created" time accurately. However, when you click the post name to view the discussion, all listed times are 7 hours earlier than the actual time. Here are screenshots of this issue in action:

 

Test Post is created with a 4:26 PM timestamp (Pacific Standard Time)

ThomasShaw_0-1588350634420.png

Test Post thread shows 9:26 AM timestamp. Note the tool-tip lists the correct 24-hour timestamp.

ThomasShaw_1-1588350704466.png

 

From all the forums I've read through there were two obvious placed to check; personal regional settings in Delve, and administrator regional settings for the site. The admin settings are configured for Pacific Standard Time (as you can see from the example below) and my Delve account has been set to use those settings configured by the administrator (me).

 

SharePoint site settings:

ThomasShaw_2-1588350916659.png

 

My personal Delve settings:

ThomasShaw_3-1588350944220.png

 

I have tried updating my Office 365 regional settings through PowerShell, confirming search schema for created and modified dates, I tried to manually adjust the "Flat" view for the post to format the create and modified columns but nothing works. We're trying to get a discussion board set up for parents coping with home-schooling during the COVID pandemic, and I can't put this discussion board into production if users are going to be asking me everyday why their post time is incorrect. Any help with this would be absolutely appreciated. Thank you!

6 Replies
Highlighted

@ThomasShaw As I posted this I questioned whether I actually did confirm the crawl properties for "created" so I checked and they weren't all mapped. In the image below, the highlighted properties were not mapped to anything so I added in Created and re-indexed the site for good measure. I'll post an update this afternoon. Hopefully by then something will change.

 

ThomasShaw_0-1588352271010.png

 

Highlighted

@ThomasShaw After 5 hours there's been no change to the way these dates are displayed.

Highlighted

@ThomasShaw We are having exactly the same issue and opened a support ticket with no definite answers yet. I'll post an update here if we hear anything from them that can help solve this issue. 

Highlighted

@Mara Lanz @ThomasShaw 
Having the same issue in my SP Online environment. Anxious to see if either of you have made progress. We are also logging a ticket with MS, so I'll share any new info here.

Highlighted
Best Response confirmed by ThomasShaw (New Contributor)
Solution

@ThomasShaw @SharePointEmily  After a few weeks of troubleshooting MS was able to find, test and release a global solution. The fix already made it to our tenant, check again, hopefully it made it yours as well.

Highlighted

@Mara Lanz I honestly thought I was alone so we just switched to Microsoft Teams for this specific case. I did however just create another discussion board and it looks like the fix was applied and works!! Thank you for going down that avenue and taking the time to reply, I really appreciate it. It's nice to know we have that functionality back.