SP List permissions not propagating on item level...

%3CLINGO-SUB%20id%3D%22lingo-sub-1372092%22%20slang%3D%22en-US%22%3ESP%20List%20permissions%20not%20propagating%20on%20item%20level...%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1372092%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ewe%20have%20a%20site%20with%20standard%20setting%2C%20standard%20permissions%20and%20nothing%20else%20that%20after%207%20years%20of%20SP%20work%20can%20think%20of%20that%20causes%20this%20behavior%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAll%20list%20items%20on%20this%20site%2C%20in%20existing%20and%20new%20lists%2C%20completely%20ignore%20the%20list-level%20permissions.%20It%20doesn't%20make%20any%20difference%20what%20I%20set%20at%20list-level%2C%20no%20items%20adopt%20these.%20E.g.%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EList%20permissions%20are%20set%20to%3A%3C%2FP%3E%3CUL%3E%3CLI%3EGroup%20Owners%20-%20Full%20Control%3C%2FLI%3E%3CLI%3EGroup%20Members%20-%20Edit%3C%2FLI%3E%3CLI%3EGroup%20Visitors%20-%20Read%3C%2FLI%3E%3CLI%3ECustom%20Group%201%20-%20Read%3C%2FLI%3E%3CLI%3ECustom%20Group%202%20-%20Edit%3C%2FLI%3E%3C%2FUL%3E%3CP%3EBut%20all%20items%20only%20have%3A%3C%2FP%3E%3CUL%3E%3CLI%3EGroup%20Owners%20-%20Full%20Control%3C%2FLI%3E%3CLI%3EGroup%20Members%20-%20Edit%3C%2FLI%3E%3C%2FUL%3E%3CP%3EThis%20means%20visitors%20can%20see%20the%20list%2C%20but%20no%20items.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20list%20item%20access%20settings%20are%20set%20correctly%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22settings.png%22%20style%3D%22width%3A%20632px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F189938i5BB2CA6A2702C3F4%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22settings.png%22%20alt%3D%22settings.png%22%20%2F%3E%3C%2FSPAN%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ELike%20I%20mentioned%2C%20this%20happens%20for%20any%20existing%20and%20new%20list%2C%20so%20I%20don't%20think%20this%20is%20a%20list%20issue....%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%3F%20I'm%20stumped...%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1372092%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPermissions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1372385%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20List%20permissions%20not%20propagating%20on%20item%20level...%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1372385%22%20slang%3D%22en-US%22%3ESo%20even%20if%20you%20take%20a%20new%20list%20and%20remove%20custom%20permissions%20and%20the%20break%20permissions%20and%20add%20the%20guest%20group%20it%20still%20doesn%E2%80%99t%20work%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1372982%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20List%20permissions%20not%20propagating%20on%20item%20level...%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1372982%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3BThat's%20right....%20Even%20if%20I%20create%20a%20new%20list%20it%20doesn't%20work%20%3Ap%3C%2Fimg%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22item%20level.png%22%20style%3D%22width%3A%20351px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F190013iC6E290F78B5D05EF%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22item%20level.png%22%20alt%3D%22item%20level.png%22%20%2F%3E%3C%2FSPAN%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22list%20permissions.png%22%20style%3D%22width%3A%20722px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F190014iEA18877C9E248DB2%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22list%20permissions.png%22%20alt%3D%22list%20permissions.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1377831%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20List%20permissions%20not%20propagating%20on%20item%20level...%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1377831%22%20slang%3D%22en-US%22%3EIs%20the%20lock%20down%20mode%20site%20collection%20feature%20on%3F%20I%E2%80%99ve%20seen%20that%20cause%20some%20odd%20issues%20in%20the%20past.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1386757%22%20slang%3D%22en-US%22%3ERe%3A%20SP%20List%20permissions%20not%20propagating%20on%20item%20level...%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1386757%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3BUnfortunately%20this%20is%20not%20the%20case.%20%3A(%3C%2Fimg%3E%20The%20feature%20is%20not%20enabled%2C%20neither%20would%20there%20have%20been%20an%20opportunity%20for%20the%20users%20to%20enable%20it.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Hi all,

 

we have a site with standard setting, standard permissions and nothing else that after 7 years of SP work can think of that causes this behavior:

 

All list items on this site, in existing and new lists, completely ignore the list-level permissions. It doesn't make any difference what I set at list-level, no items adopt these. E.g.:

 

List permissions are set to:

  • Group Owners - Full Control
  • Group Members - Edit
  • Group Visitors - Read
  • Custom Group 1 - Read
  • Custom Group 2 - Edit

But all items only have:

  • Group Owners - Full Control
  • Group Members - Edit

This means visitors can see the list, but no items.

 

The list item access settings are set correctly:

 

settings.png 

 

Like I mentioned, this happens for any existing and new list, so I don't think this is a list issue....

 

Any ideas? I'm stumped...

4 Replies
Highlighted
So even if you take a new list and remove custom permissions and the break permissions and add the guest group it still doesn’t work?
Highlighted

@Chris Webb That's right.... Even if I create a new list it doesn't work :p

 

item level.pnglist permissions.png

Highlighted
Is the lock down mode site collection feature on? I’ve seen that cause some odd issues in the past.
Highlighted

@Chris Webb Unfortunately this is not the case. :( The feature is not enabled, neither would there have been an opportunity for the users to enable it.