SP 2013 & 2012R2 Installation Issue

%3CLINGO-SUB%20id%3D%22lingo-sub-1539179%22%20slang%3D%22en-US%22%3ESP%202013%20%26amp%3B%202012R2%20Installation%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1539179%22%20slang%3D%22en-US%22%3E%3CP%3EDoing%20some%20migration%20work%20and%20need%20a%20stove%20pipe%202013%20farm.%26nbsp%3B%20I%20can't%20seem%20to%20resolve%20this%20error%3A%26nbsp%3B%20This%20product%20requires%20Microsoft%20.Net%20Framework%204.5.%26nbsp%3B%20This%20article%20seems%20stale%20as%20there%20is%20no%20ZIP%20to%20download%20..%20only%20exes.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Ftroubleshoot%2Finstallation-and-setup%2Fsetup-error-if-.net-framework-4.6-is-installed%23status%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Ftroubleshoot%2Finstallation-and-setup%2Fsetup-error-if-.net-framework-4.6-is-installed%23status%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20help%20would%20be%20greatly%20appreciated.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1539179%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2013%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1539336%22%20slang%3D%22en-US%22%3ERe%3A%20SP%202013%20%26amp%3B%202012R2%20Installation%20Issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1539336%22%20slang%3D%22en-US%22%3E%3CP%3EHad%20to%20hack%20the%20registry%20to%20fake%20out%20the%20install.%26nbsp%3B%20If%20another%20solution%20is%20out%20there%2C%20please%20offer%20it%20up.%26nbsp%3B%20Thanks.%3C%2FP%3E%3CP%3E1.%26nbsp%3B%20Granted%20my%20admin%20account%20Owner%20access%20to%20this%20key%3A%26nbsp%3B%26nbsp%3BHKEY_LOCAL_MACHINE%5CSOFTWARE%5CMicrosoft%5CNET%20Framework%20Setup%5CNDP%5Cv4%3C%2FP%3E%3CP%3E2.%26nbsp%3B%20Ran%20the%20SwitchRegTo4.5.reg%20(see%20zip)%3C%2FP%3E%3CP%3E3.%26nbsp%3B%20Ran%20the%20SP2013%20Install%20without%20running%20Config%20Wizard%3C%2FP%3E%3CP%3E4.%26nbsp%3B%20Ran%20the%20SwitchRegTo4.8.reg%20(the%20original%20..%20see%20zip)%3C%2FP%3E%3CP%3E5.%26nbsp%3B%20Rebooted%3C%2FP%3E%3CP%3E6.%26nbsp%3B%20Proceeded%20with%20Config%20Wizard%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Doing some migration work and need a stove pipe 2013 farm.  I can't seem to resolve this error:  This product requires Microsoft .Net Framework 4.5.  This article seems stale as there is no ZIP to download .. only exes.

 

https://docs.microsoft.com/en-us/sharepoint/troubleshoot/installation-and-setup/setup-error-if-.net-...

 

Any help would be greatly appreciated.

1 Reply
Highlighted

Had to hack the registry to fake out the install.  If another solution is out there, please offer it up.  Thanks.

1.  Granted my admin account Owner access to this key:  HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\NET Framework Setup\NDP\v4

2.  Ran the SwitchRegTo4.5.reg (see zip)

3.  Ran the SP2013 Install without running Config Wizard

4.  Ran the SwitchRegTo4.8.reg (the original .. see zip)

5.  Rebooted

6.  Proceeded with Config Wizard