Some users unable to browe SharePoint within Office apps

New Contributor



We recently performed a tenant-to-tenant migration of all mailboxes and documents (SharePont and OneDrive) using BitTitant's MigratonWiz and it went quite smoothly for the most part.


However, we're seeing some strange behaviour with about 50% of our users unable to browse documents on SharePoint within Office apps (Word, Excel, etc), instead getting the message "There are no sites to show right now" when they click on "Sites - 'Site Name'". OneDrive access in the same manner ("OneDrive - 'Site Name'") is fine though. And to add further to the mystery, the OneDrive client, for those who use it and experiencing the issue, also allows SharePoint browsing.


Example of the issue (not my screenshot):



What my users should be seeing:



Initially I thought it might have been SharePoint permissions or caching of the old tenant's details on user workstations, but logging into SharePoint via a web browser and resetting the local profiles respectively did not work. Even setting up a user on a freshly imaged laptop, using a local account (no roaming) resulted in the same issue after they signed into Office.


I've tried having users sign out and back in multiple times in Office apps and via the website. I've tried removing someone's SharePoint license, waited 12+ hours, re-applied the license, without it fixing the issue. I've verified SharePoint permissions, even though I don't think that's the cause.


I'm honestly not sure what else to try at this point, other than re-creating the affected users entirely...Although I'm not sure how fiddly this would be with us using AAD Connect....


Any thoughts/advise will be most appreciated.



4 Replies
Best Response confirmed by mrhcarlin (New Contributor)
I don't like having users use that method, I try to train them to go through Teams or SharePoint itself to open files. Or utilize and the recent section and search. It's a much better experience to find files.

Anyway, to the actual issue.

Have these users actually had information there before? YOu said they switched tenants? If so have they actually gone to these SharePoint sites manually and opened files? They wont' appear till they actually visit the sites and do some activity. You can force the hand by having the user go to the site and Follow (Top right of home page) this should then add it to the list in a Followed section. That's the guaranteed way to get access to them via Open command.
Hi Chris,

Amazingly that worked! I'm a bit miffed that that's how it does work, though, because requiring the user to do "some stuff" in SharePoint in a web browser first just seems a bit...random? And 'random' seems an appropriate word because the site appeared in Office apps for some users near instantaneously, but other users it took several minutes. And in all cases I told them to "do some stuff" in and favourite the the site.

Still, at least I now know what the issue is and how to fix it (somewhat).

Out of interest, I don't suppose you know if there's a way to force it as a favourite site for all users (perhaps with some PowerShell magic)?


Don't think there is, I've been trying to figure it out over the years, and no where have I seen it, so I think it's just not possible ;).

The randomness has to do with graph and or search index, so it probably runs on a timer to generate those flags on users so some happened to visit right around the time it updated, so they noticed it right away, others on the tail end of a pass.
Ok, no worries! Thanks for the help. :)