Site Permissions - Full Control AND Limited Access as owner/only user?

Copper Contributor



I made a site awhile go and never used it. Ended up changing the name to possibly use the site differently, but also never used it. I am the site owner and only user on the site. However, when I tried to delete it, it told me I didn't have access? So I went and gave myself Full Control access (again), and it's just an endless loop of requesting access and approving. When I checked my permissions, the screenshot below is what I get. How can I fix this so I can delete this site?


Screenshot (13).png

2 Replies
Have you tried adding yourself into the default Site Owner group that is provisioned when SPO sites are created? It is generally recommended to leverage the default groups over granting permission directly to a user. This assumes your organization uses the default groups that are typically created with Site creation.
There may be policies preventing you from deleting the site. Check with your Admin.