SharPoint Seach Result date column gives NaN-NaN-NaN

%3CLINGO-SUB%20id%3D%22lingo-sub-117151%22%20slang%3D%22en-US%22%3ESharPoint%20Seach%20Result%20date%20column%20gives%20NaN-NaN-NaN%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-117151%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20there%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20an%20SP%20site%20with%203%20documentlibraries.%20At%20my%26nbsp%3Bhome%20page%20i%26nbsp%3Bmake%20use%20of%20the%20standard%20search%20results%20web%20part.%20I%20connected%20that%20webpart%20to%20the%203%20document%20libraries%20(with%20a%20contenttype%20used%20in%20all%203).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20de%20standard%20colum%20%22last%20modified%22%20i%26nbsp%3Bmanually%20select%20the%20date%20column%20LastModified.%20But%20than%20in%20my%20view%20i%26nbsp%3Bget%20a%20NaN-NaN-Nan%26nbsp%3Bmessage.%26nbsp%3BAfter%201%20day%20(suspected%20the%20full%20crawl%2C%20its%20a%20SPO%20enviroment)%20the%20date%20is%20show%26nbsp%3Bin%20most%20of%20the%20cases%2C%20but%20not%20all!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESee%26nbsp%3Bthe%20attachment%26nbsp%3Bfor%20more%20info.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20what%20the%20issue%20is%20here%3F%20i%20dont%20want%20to%26nbsp%3Bwait%26nbsp%3B1%20day%26nbsp%3Bbefore%20i%20see%20the%20correct%20day.%20I%20dont%20want%20the%20NaN-NaN-Nan%20message%2C%26nbsp%3Bmy%20clients%20wont%20like%20that.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance!%3C%2FP%3E%3CP%3E%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-117151%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-119060%22%20slang%3D%22en-US%22%3ERe%3A%20SharPoint%20Seach%20Result%20date%20column%20gives%20NaN-NaN-NaN%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-119060%22%20slang%3D%22en-US%22%3E%3CP%3EHI%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F18458%22%20target%3D%22_blank%22%3E%40Rob%20Giesen%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20a%20bug%20in%20the%20display%20template%20that%20is%20being%20used.%20Are%20you%20using%20custom%20display%20templates%20or%26nbsp%3B%20one%20of%20the%20out%20of%20the%20box%20ones%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20problem%20here%20is%20that%20there%20will%20be%20some%20javascript%20reading%20an%20invalid%20date.%20Ideally%20the%20scripts%20should%20handle%20the%20invalid%20that%20and%20that%20is%20exactly%20what%20it%20is%20doing.%20Unfortunately%20it%20does%20this%20as%20NaN.%20Of%20course%20this%20isn't%20very%20friendly.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECould%20you%20have%20a%20look%20at%20the%20document%20in%20question%20and%20see%20what%20the%20modification%20date%20is%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAlso%20can%20you%20post%20which%20templates%20you%20are%20using%3F%20My%20guess%20is%20that%20the%20item%20template%20has%20something%20wrong%20with%20it.%20Finally%20it%20could%20be%20the%20managed%20property%20that%20is%20used%20for%20the%20Modification%20date.%20Have%20any%20changes%20been%20made%20to%20the%20managed%20property%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-119055%22%20slang%3D%22en-US%22%3ERe%3A%20SharPoint%20Seach%20Result%20date%20column%20gives%20NaN-NaN-NaN%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-119055%22%20slang%3D%22en-US%22%3E%3CP%3EFull%20crawling%20is%20not%20the%20issue%20because%20Crawls%20are%20continuous%20in%20SPO%2C%20that%20looks%20like%20a%20bug%20to%20me%2C%20I%20would%20open%20a%20support%20ticket%20with%20MS.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Contributor

Hello there,

 

I have an SP site with 3 documentlibraries. At my home page i make use of the standard search results web part. I connected that webpart to the 3 document libraries (with a contenttype used in all 3).

 

In de standard colum "last modified" i manually select the date column LastModified. But than in my view i get a NaN-NaN-Nan message. After 1 day (suspected the full crawl, its a SPO enviroment) the date is show in most of the cases, but not all!

 

See the attachment for more info.

 

Does anyone know what the issue is here? i dont want to wait 1 day before i see the correct day. I dont want the NaN-NaN-Nan message, my clients wont like that.

 

Thanks in advance!

  

2 Replies

Full crawling is not the issue because Crawls are continuous in SPO, that looks like a bug to me, I would open a support ticket with MS.

HI @Rob Giesen,

 

This is a bug in the display template that is being used. Are you using custom display templates or  one of the out of the box ones?

 

The problem here is that there will be some javascript reading an invalid date. Ideally the scripts should handle the invalid that and that is exactly what it is doing. Unfortunately it does this as NaN. Of course this isn't very friendly. 

 

Could you have a look at the document in question and see what the modification date is? 

 

Also can you post which templates you are using? My guess is that the item template has something wrong with it. Finally it could be the managed property that is used for the Modification date. Have any changes been made to the managed property?