Sharing problems in Sharepoint (sharing options greyed out)

Copper Contributor



I'd like to ask for help with a problem regarding sharing options in Sharepoint.

We are using "modern sharepoint"


The options for choosing what kind of sharing the users want to do are greyed out:

Users can't choose - Anyone with link; People in X-organizatoin with the link


"Your organizatoin is preventing you from selecting this option"


The settings are correct - 
Admin Center - Policies:


Admin Center -> Active Sites -> Site -> Sharing:



I've gone through the official documentation

Sharing options are greyed out when sharing from SharePoint Online 

As well as couple of blogs describing this problem, no luck.

I, as admin/owner of the site, can share without limitations, it's the users within the group Members that have the options greyed out.
I've tried to see what settings are on offer within the archaic Sharepoint permissoin editor, but no settings are to be found for the user group that relate to sharing.


The issue persists throughout the site, not just one library.


* I have also tried setting the sharing capability via Powershell.
Here is the result:


And this is what the "ordinary" user, that is in the group Members, continues to see:



Any help would be greatly appreciated,

4 Replies



We are experiencing this too and have discovered a few things, with no solution. 


Members typically are assigned "Edit" site permissions (I assume). At first, this role had the "Anyone with a link can..." option available. However, we do not want our Members to be able to have the ability to delete, for example. I modified the "Edit" permission level by unchecking "Delete Items" and when I did, the "Anyone with a link can..." option for Members became grayed out. After trial and error I determined that, for whatever reason, ALL boxes under "List Permissions" have to be checked or  "Anyone with a link can..." will not be available. 


I'm attempting to figure out a solution to this and joined this group moments ago to ask this community for help. Maybe our issue is the same? 


If you happen to have found a solution, I'd be grateful to learn what it was. 


Thank you!


I spent weeks on this, The way I got it to work was


  1. go to the "sites" tab in share pane admin
  2. Click on the site you want to change permissions for
  3. Chooses the policies tab
  4. click edit under external sharing
  5. change it to anyone



Hey there, I have experienced the same thing you bring up here. To resolve this you need to remove the Limited-Access User Permission Lockdown Mode.


  1. Go to Your site collection >> Click on Settings Gear >> Click on “Site Information” >> Click on the “View All Site Information” link.
  2. Under the site settings page, click on “Site Collection Features”.
  3. Click on the “Deactivate” button next to the “Limited-access user permission lockdown mode” feature and confirm the prompt on the next page.

More info here: