Sharing a document library with external users

Occasional Contributor

Is anyone running into problems with external user access on SharePoint Online sites since yesterday (15 Sep 2016)? I have my gmail address set as alias on my account and I've used this to access SPO site as external user in the past. I tried sharing a new SPO site to me gmail address and got a email invite in my gmail. When I try to access it using me gmail address as user name and its password (in the login page, I choose 'Microsoft Account' from the available options 'Microsoft account' & 'Organizational account'), I get redirect to login page and there after an error "Your account or password is incorrect. If you don't remember your password, reset it now"...


This is insane. I know my gmail password and I'm logged into it. Just for troubleshooting, When I clicked "Create a Microsoft account, it's quick and easy!" on the 'Welcome to SharePoint Online page" and entered by gmail address, I got an immediate response indicating ' is already a Microsoft account.' (confirming that the alias is valid)....

17 Replies
Weird...not seeing this problem, but it could be to the fact that Microsoft is doing changes with Live IDs and organization IDs...but you are not using an organization ID...

Reset you password.  I had this same issue with OneDrive a few weeks back and a password reset fixed the issue.  It's dumb but it worked.

Nope...I'm not using org ID...I made sure that I tried this in private browsing made so that my org ID login and external login do not interfere...

Its so annoying with lot of changes going on with SharePoint Online...I've seen a lot of issues this week.
You mean reset my gmail or password?
Your gmail/microsoft account password
Nope...didn't work...

When I login as external user, I should be able to use the external email address and Microsoft account password, right? Before and after password reset, I get this message:

" That didn't work
You're trying to accept your invitation with

This item is shared with This organization's policy requires you to accept the invitation using the account that is shared with.


" That didn't work
You're trying to accept your invitation with


Can you log in with your gmail address without clicking on the invitation link?  You shouldn't be forced to use unless that's your gmail/microsoft account name.  Log in, then accept invite?


What are the sharing permissions on the site, collection and tenant levels?

That doesn't work either...

External Sharing enabled at both tenant and site collection level. On the site level, it's read access...

This sounds like it is related to a relatively new admin setting for external sharing. If you are a SharePoint admin in your tenant, go to the SharePoint admin page and then "Sharing" on the left.


I see this when I go to mine:





Notice in the middle of the screen, under additional settings:

External users must accept sharing invitations using the same account that the invitations were sent to


If that box is checked, then you must accept the invitation using the same email that it was sent to.

In my case, it was already checked by default. So, didn't help with the error :)


I have a case open with Microsoft to find out more on this...

Arut -- the box was checked? If so, then this is expected behavior.  You must accept the sharing invitation with a user account that has the same email address that the invitation was emailed to.

@Deleted I think the issue is that it's not allowing him to accept the invitation with the email address it was sent to.


You mentioned "user account", are you saying the account accepting the invite must be a user in your org or just using it as a general term?

@Deleted @Anthony Gorhum

As pointed out by Anthony, it doesn't let me sign in using any of the email addresses. To clarify more on this:


I have my gmail address set up as alias on my email address. I login to the SharePoint online site using my org account (which is different from gmail & account) and share the site with my gmail address.


Now, I open the browser in private mode and sign in to my gmail account. I see the invite email from Microsoft online (indicating that my org ID has shared the site) and I click on the link in the email. I get redirected to a page which lets me choose between organization account vs Microsoft account to login and I choose Microsoft account & get redirected to Microsoft login page.


As far as I can remember, I used to be able to use my gmail address and gmail password as the username/ password. Now, it throws me an error indicating username or password is incorrect. At this point, if I use (either the address or) gmail address with password, it gives me an error indicating the site was shared with my gmail address and I should try to use the same (& not the address).


Hope this makes sense?

Which address did you send the invite to?  Maybe the alias is the problem.  Try sharing it with both addresses and then accept the invites from their native space.  Perhaps accepting the invite sent to your outlook email address from ms account would clear things up.  


Something else to try would be to setup a new account in gmail and then create a ms account with it.  Try sharing to this account and see what happens.


I know this isn't overly helpful, but this issue is random and it sounds like you've taken all of the normal avenues to resolve it.

@Anthony Gorhum To answer your first question, the actual external users are having their own company email address and its already an overhead asking them to set-up their company email address as alias of an Windows Live or account. Now, asking them to use account completely for this SharePoint site will not hold up good with them based on my conversation with them so far.


I can and will try to set up a new gmail account, but I'm afraid if the current process is broken and we have to set up new accounts/ aliases with or Windows Live account, then its going to be a huge problem for us. Nevertheless, I will try this out from a troubleshooting perspective.

@Arut Jothidid you solve this?

I just came across it but it seems to be a problem with default aliases. I ran into similar issues with my main account that has always had just one custom domain as a primary alias. 

I was having loads of issues with Outlook failing to authenticate (the custom domain was also an Office 365 enabled domain) and eventually the fix was to create an alias and make that the primary. 

In your case it looks like you need to make your alias your primary alias in your Outlook/Microsoft account. What's happening is you are probably successfully logging in to your MSFT account with either alias but then when authenticating to SPO it only looks at the primary alias which doesn't match the email address the item was shared with.

I have come across this issue as well, the new external sharing changes will resolve these problems: