Sharepoint Won't open Custom Forms on migrated site

%3CLINGO-SUB%20id%3D%22lingo-sub-1580742%22%20slang%3D%22en-US%22%3ESharepoint%20Won't%20open%20Custom%20Forms%20on%20migrated%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1580742%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20all%2C%26nbsp%3B%3C%2FP%3E%3CP%3Ewe%20are%20in%20the%20middle%20of%20a%20sharepoint%20online%20migration%20from%20a%20tenant%20to%20another.%26nbsp%3B%3C%2FP%3E%3CP%3EIn%20the%20source%20tenant%20we%20have%20many%20list%20with%20custom%20forms%20built%20during%20the%20years%20through%20microsoft%20designer.%3C%2FP%3E%3CP%3EWe%20have%20migrated%20some%20of%20these%20custom%20solutions%3B%20in%20the%20new%20tenant%20sharepoint%20keep%20opening%20the%20basic%20sharepoint%20form%20(the%20vertical%20one%20on%20the%20right%20hand%20panel)%20even%20though%20the%20custom%20form%20built%20with%20designer%20is%20set%20as%20default.%20The%20custom%20form%20is%20accessible%20through%20the%20link%20directly.%3C%2FP%3E%3CP%3EInside%20Designer%2C%20the%20custom%20forms%20are%20set%20as%20default%2C%20but%20on%20sharepoint%20they%20won't%20open%20by%20default%20unless%20we%20set%20each%20list%20in%20classic%20mode.%20Things%20we%20can't%20do%20due%20to%20customization%20on%20columns.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20else%20experienced%20something%20like%20this%3F%3C%2FP%3E%3CP%3EInfo%20path%20forms%20work%20fine%20after%20being%20re%20published.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1580742%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ECustom%20List%20Forms%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDesigner%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1603837%22%20slang%3D%22en-US%22%3ERe%3A%20Sharepoint%20Won't%20open%20Custom%20Forms%20on%20migrated%20site%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1603837%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F272053%22%20target%3D%22_blank%22%3E%40bosco93%3C%2FA%3E%26nbsp%3BIt%20is%20possible%20that%20it%20is%20related%20to%20to%20%3CA%20href%3D%22https%3A%2F%2Fanswers.microsoft.com%2Fen-us%2Fmsoffice%2Fforum%2Fall%2Funable-to-create-custom-forms-in-sharepoint%2Faff26ff9-5da4-4230-9f85-7a3e72f0f36b%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ethis%20information%3C%2FA%3E%20that%20was%20published%20in%20MC210713%20in%20Microsoft%20admin%20center%20-%20Message%20center%20earlier%20this%20year.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ERegards%2C%20Magnus%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

Hi all, 

we are in the middle of a sharepoint online migration from a tenant to another. 

In the source tenant we have many list with custom forms built during the years through microsoft designer.

We have migrated some of these custom solutions; in the new tenant sharepoint keep opening the basic sharepoint form (the vertical one on the right hand panel) even though the custom form built with designer is set as default. The custom form is accessible through the link directly.

Inside Designer, the custom forms are set as default, but on sharepoint they won't open by default unless we set each list in classic mode. Things we can't do due to customization on columns.

 

Has anyone else experienced something like this?

Info path forms work fine after being re published. 

 

2 Replies

@bosco93 It is possible that it is related to to this information that was published in MC210713 in Microsoft admin center - Message center earlier this year.

 

Regards, Magnus

@Magnus GoksøyrIt could be, but the use of existing form should be allowed!

I have this problem again now, in some lists sharepoint randomly opens the default right side form instead of the custom one even if all the settings are correct.

This is quite annoying for the user.