SharePoint Site Pages Assets not Displaying on Shared Link

%3CLINGO-SUB%20id%3D%22lingo-sub-1542102%22%20slang%3D%22en-US%22%3ESharePoint%20Site%20Pages%20Assets%20not%20Displaying%20on%20Shared%20Link%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1542102%22%20slang%3D%22en-US%22%3E%3CP%3EHello!%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20created%20a%20SharePoint%20Site%20page%20within%20the%20SharePoint%20group%20from%20MSTeams.%26nbsp%3B%20I've%20added%20images%20that%20serve%20as%20icons%20for%20links%20to%20other%20documents%2C%20external%20sites%2C%20etc.%26nbsp%3B%20I%20have%20set%20a%20sharing%20link%20for%20access%20to%20anyone%20within%20my%20organization%20who%20is%20not%20part%20of%20the%20SharePoint%20group%20to%20view%20the%20page.%26nbsp%3B%20The%20link%20works%20fine%20and%20directs%20individuals%20outside%20of%20our%20MSTeam%20group%20to%20the%20page%2C%20however%2C%20the%20images%20on%20the%20page%20do%20not%20display%20for%20these%20viewers.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20made%20the%20site%20assets%20folder%20viewable%20by%20anyone%20within%20the%20organization%2C%20and%20I%20have%20made%20the%20images%20I've%20uploaded%20viewable%20by%20anyone%20within%20the%20organization%20as%20well.%26nbsp%3B%20Still%2C%20when%20someone%20who%20is%20not%20part%20of%20the%20core%20MSTeam%20views%20the%20page%2C%20all%20they%20see%20are%20silhouettes%20of%20where%20the%20image%20should%20be.%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20pointers%20on%20how%20to%20make%20this%20work%3F%26nbsp%3B%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1542102%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFiles%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPermissions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1542333%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Site%20Pages%20Assets%20not%20Displaying%20on%20Shared%20Link%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1542333%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F669377%22%20target%3D%22_blank%22%3E%40Veetor%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENot%20quite%20sue%20what%20the%20issue%20is%20but%20rather%20than%20give%20permissions%20via%20a%20sharing%20link%20try%20and%20give%20permissions%20directly%20to%20the%20page%20like%20you%20have%20for%20the%20assets%20and%20images.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThen%20just%20give%20users%20the%20URL%20of%20the%20page.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor

Hello! 

 

I have created a SharePoint Site page within the SharePoint group from MSTeams.  I've added images that serve as icons for links to other documents, external sites, etc.  I have set a sharing link for access to anyone within my organization who is not part of the SharePoint group to view the page.  The link works fine and directs individuals outside of our MSTeam group to the page, however, the images on the page do not display for these viewers.  

 

I have made the site assets folder viewable by anyone within the organization, and I have made the images I've uploaded viewable by anyone within the organization as well.  Still, when someone who is not part of the core MSTeam views the page, all they see are silhouettes of where the image should be.  

 

Any pointers on how to make this work?  

1 Reply

@Veetor 

 

Not quite sue what the issue is but rather than give permissions via a sharing link try and give permissions directly to the page like you have for the assets and images. 

 

Then just give users the URL of the page.