Sharepoint Site Links not working in Teams

Copper Contributor

I've created a Sharepoint Site for a project that we need to share internally - we need it accessible via Teams.


We have added it as a tab in Teams, but it's not working properly. The majority of people are unable to click the links and are stuck on the homepage unless they open the site in their browser. This is not ideal as we want to keep our users in Teams.


We have used both Sharepoint and Website linking features within teams and both run into the same issue.


Does anyone have any insight into this issue and how to resolve it?

26 Replies

@Andres Gorzelany Thanks, it does look like the same sort of issue. There doesn't seem to be a resolution in that thread though :(

Unfortunately not, but I'll try to dig into this
Hi - I have noticed the same issue, any fix yet? No changes have been my our side as far as i'm aware and was previously working fine, thanks
It is working for me now. Entirely unsure why! I added the tab to a private channel so I could experiment with it and it was working. So I deleted the tab in the teams channel where it wasn't working and re-added & it is miraculously working. Age old joke of turning things off and on again a few times in IT.

Thanks @EmilyRM - have give that a go but unfortunately still the same for me, hopefully the issue is identified soon and a fix published, thanks again :) 

Thanks for opening this question. This way, I know there are multiple people facing the same issue. Hopefully, Microsoft will fix it soon. I have the same problem and can't get the links to work. It lessens the usefulness of teams for our company.
The problem is appearing in the teams web version, teams desktop version, and across all link types I set up on the Sharpoint website. It only works when accessing Sharepoint via the browser

I seem to be having the same issue. It was working fine last week and I went to open the Sharepoint site from teams this morning and the page is blank.  Everyone is having the same issue. Interesting to note that the site is accessible through a browser though.

I think I got a solution guys: After a brief discussion with out IT-Support service contractor he advised us to embed the site as as "SharePoint"-Website, not a "Website"-Website. Seems like its all working so far. The attached image is in german, but the menu should look similar

@JonasM123Thanks for the update, it's worked for me also. I added the new tab in Teams as a 'SharePoint Pages' tab and then selected 'add page from any SharePoint site' and inserted the site URL (like you would also do for the 'Website' tab).

@JonasM123 I'm not trying to add it as a page on a team. I am trying to add it in the apps pinned to the left. But it only gives me the option to add "SharePoint" to a team. Weird that it's working fine for some employees not others.
I'm getting the same issue. In the space of the same day I've been able to, and unable to, add a Sharepoint site as a tab to a Team.
  • @JonasM123 i have the same issue, and on my side it's already added as sharepoint, i deleted and readded it but still not working

Hello, same issue here, but affecting only the links to url's that contain blanks (%20).
The issue started on different Teams of our tenant on February 14th 2023 and still ongoing.


I raised a support ticket and on our tenant, the issue got fixed by Microsoft on February 17th.
Kr, Peter

@Peter_Geebelen What was the fix from Microsoft as I am getting the exact same problem?

Hi, Last Friday when it worked again, the support engineer mentioned that the backend team probably rolled-out a fix for this bug. Unfortunate the issue is reoccurring since this morning on our tenant. I re-opened the support case, and am waiting on feedback. Kr, Peter
Thanks Peter.
Hopefully a fix can be found as it is very frustrating and I have trawled through the internet at all sorts of possible fixes/ none that actually fix the issue.
Hi Peter. I'm currently facing the same issue. When trying to access a folder using a link to said folder on the Team site, in an embedded SharePoint tab in Teams, I get a "This site might not exist anymore link" errorpages. Works fine, when using the SharePoint-page in any given browser (In this case using Edge). Please be so kind as to update me as well when you've heard back from MS.