SharePoint Search wrong ContentType and ContentTypeId for Modern Sites

%3CLINGO-SUB%20id%3D%22lingo-sub-1023716%22%20slang%3D%22en-US%22%3ESharePoint%20Search%20wrong%20ContentType%20and%20ContentTypeId%20for%20Modern%20Sites%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1023716%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ecurrently%20I%20am%20facing%20a%20issue%20with%20the%20SharePoint%20Online%20Search%20and%20Modern%20Pages.%3C%2FP%3E%3CP%3EI've%20got%20SitePages%20with%20a%20different%20ContentType%20and%20want%20to%20search%20for%20these%20articles%20by%20the%20ContentTypeId%20or%20Name.%20But%20the%20SharePoint%20Crawler%20seems%20to%20get%20only%20the%20base%20contenttype%20%22Site%20Page%22.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20seems%20to%20be%20something%20wrong%20with%20search.%20Also%20the%20ContentType%20field%20is%20showing%20%22text%2Fhtml%3B%20charset%3Dutf-8%20%3CSPAN%3E%26nbsp%3BSite%20Page%22.%20It%20looks%20like%20the%20crawler%20is%20not%20able%20to%20read%20modern%20sites%20properly.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EI%20was%20able%20to%20reproduce%20the%20issue%20on%20different%20tenant%20with%20default%20site%20page.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EIs%20someone%20facing%20the%20same%20problem%20or%20got%20a%20solution%20for%20that%3F%20%3A)%3C%2Fimg%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20400px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F158313i6EE530090A5FC4B1%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1023716%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Occasional Contributor

Hello,

 

currently I am facing a issue with the SharePoint Online Search and Modern Pages.

I've got SitePages with a different ContentType and want to search for these articles by the ContentTypeId or Name. But the SharePoint Crawler seems to get only the base contenttype "Site Page". 

 

There seems to be something wrong with search. Also the ContentType field is showing "text/html; charset=utf-8  Site Page". It looks like the crawler is not able to read modern sites properly.

 

I was able to reproduce the issue on different tenant with default site page.

Is someone facing the same problem or got a solution for that? :)

 

clipboard_image_0.png

0 Replies