SharePoint Online - Validation Settings missing from a list

%3CLINGO-SUB%20id%3D%22lingo-sub-2925837%22%20slang%3D%22en-US%22%3ESharePoint%20Online%20-%20Validation%20Settings%20missing%20from%20a%20list%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2925837%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%20I'm%20building%20a%20SPO%20list%2C%20and%20i%20want%20to%20use%20some%20validations%20in%20some%20columns%2C%20but%20I've%20noticed%20that%20when%20i%20go%20to%20List%20settings%20%26gt%3B%20under%20General%20there%20is%20no%20Validation%20Settings%20option.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20ideas%20how%20to%20make%20it%20to%20appear%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22Radoslavov91_0-1636019853479.png%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F324177i8C2FE94D2613F543%2Fimage-size%2Flarge%3Fv%3Dv2%26amp%3Bpx%3D999%22%20role%3D%22button%22%20title%3D%22Radoslavov91_0-1636019853479.png%22%20alt%3D%22Radoslavov91_0-1636019853479.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3EThank%20you%20for%20the%20help.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Eregards%3C%2FP%3E%3CP%3EKiril%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2925837%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2927787%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Online%20-%20Validation%20Settings%20missing%20from%20a%20list%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2927787%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F345126%22%20target%3D%22_blank%22%3E%40Radoslavov91%3C%2FA%3E%26nbsp%3BWhat%20is%20the%20template%20type%20of%20your%20list%3F%20Is%20it%20general%2Fcustom%20list%20or%20other%20type%20like%20tasks%2Fissues%2Fannouncements%3F%3C%2FP%3E%3CP%3EAlso%2C%20do%20you%20have%26nbsp%3B%3CSTRONG%3EFull%20Control%3C%2FSTRONG%3E%20permissions%20on%20list%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ECheck%20below%20threads%20if%20it%20helps%3A%3C%2FP%3E%3COL%3E%3CLI%3E%3CA%20title%3D%22Validation%20Settings%20Not%20Showing%20in%20List%20Settings%20SP2013%22%20href%3D%22https%3A%2F%2Fsharepoint.stackexchange.com%2Fquestions%2F162421%2Fvalidation-settings-not-showing-in-list-settings-sp2013%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noreferrer%22%3EValidation%20Settings%20Not%20Showing%20in%20List%20Settings%20SP2013%3C%2FA%3E%26nbsp%3B%3C%2FLI%3E%3CLI%3E%3CA%20title%3D%22Missing%20Validation%20Settings%20Under%20General%20Settings%22%20href%3D%22https%3A%2F%2Fsocial.technet.microsoft.com%2FForums%2Flync%2Fen-US%2F187771bf-b60b-46b4-b871-9d593627b69d%2Fmissing-validation-settings-under-general-settings%3Fforum%3Dsharepointgeneral%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3EMissing%20Validation%20Settings%20Under%20General%20Settings%3C%2FA%3E%26nbsp%3B%3C%2FLI%3E%3C%2FOL%3E%3CHR%20%2F%3E%3CP%3EPlease%20click%20%3CSTRONG%3EMark%20as%20Best%20Response%3C%2FSTRONG%3E%20%26amp%3B%20%3CSTRONG%3ELike%3C%2FSTRONG%3E%20if%20my%20post%20helped%20you%20to%20solve%20your%20issue.%20This%20will%20help%20others%20to%20find%20the%20correct%20solution%20easily.%20It%20also%20closes%20the%20item.%20If%20the%20post%20was%20useful%20in%20other%20ways%2C%20please%20consider%20giving%20it%20%3CSTRONG%3ELike%3C%2FSTRONG%3E.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi All, I'm building a SPO list, and i want to use some validations in some columns, but I've noticed that when i go to List settings > under General there is no Validation Settings option.

 

Any ideas how to make it to appear?

 

Radoslavov91_0-1636019853479.png

Thank you for the help.

 

regards

Kiril

 

4 Replies

@Radoslavov91 What is the template type of your list? Is it general/custom list or other type like tasks/issues/announcements?

Also, do you have Full Control permissions on list?

 

Check below threads if it helps:

  1. Validation Settings Not Showing in List Settings SP2013 
  2. Missing Validation Settings Under General Settings 

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

Hi ganeshsanap,

it's a blank list (no template is used), and I'm the only global admin for the tenant so i have full control.

@Radoslavov91 Is this team site or communication site?

 

Did you deactivate any site or site collection feature?


Please consider giving Like if my post helped you in any way.

Since the site where Validation settings option is missing is a Team site, I've tried to check in another site from the same type, and it is visible there for a list, Check other site and for some it is there, for others not. So it seems that it is not a global option that needs to be enabled but something on a site collection level.
Any ideas what that might be?

regards
Kiril