SharePoint Online Text Editor Ribbon Items Disappear and File Editor will not save changes

Copper Contributor

The text editor for editing files no longer has the top ribbon which allows for saving and updating files. It no longer appears after "Open In Text Editor" is selected. This disappeared in the middle of the day yesterday after successfully using it for the last 6 weeks. I have searched the web and found this to be a problem in the past with no solution. I have tried several different web browsers and different computers with the same result. Is this something that changed on my individual Sharepoint site or a known issue with Microsoft?


Note: Files can be edited and save through Sharepoint Designer, but this is not the most ideal. The ability to edit in browser is very useful.

12 Replies

We've also noticed this issue since Monday. We use the online text editor extensively as part of our workflow (to allow users to quickly update markdown files in the browser). It has been working fine for the past 6 months, but I think MS rolled out some 0365 updates over the weekend and it seems to have broken the toolbar. I remember something like this happening a while ago (some UI in SharePoint/OneDrive went missing and then it mysteriously appeared back again after a few days).


Can anyone at Microsoft confirm this is a bug that will be fixed? To reproduce:


1. Upload a text file to OneDrive

2. Using the web version of OneDrive, select the file > Open > Open in Text Editor

3. Try to edit and save the file (even the keyboard shortcut to save is not working) 


There should be a tool bar like the attached image (onedrive-toolbar-missing.jpg) which allows users to edit and save the file



@Michael Murphy  thank you for your response.


Mysteriously the ribbon reappeared today. I think you are correct that it was related to an update. I also think that it was resolved with another update today.

@intersign Happy to hear it's been resolved. Still waiting for the update here, hopefully it will appear in the next few days :crossed_fingers:

I am still experiencing issues where I click on Open in Text Editor but after I make my changes, I don't have the option to save.  @intersign 

This issue has still not been resolved for us (O365 SharePoint and Overdrive) – it's now been 9 days since it first broke. 


Do Microsoft staff monitor these forums or is there a better way to submit major issues to the team?


Also wondering if there is a publicly visible change-log for 0365 when they roll out updates… 


@Michael Murphy  after reading your post I checked to see if I was still able to see the text editor ribbon because I have not used it in several days. Unfortunately mine disappeared again!?


Can someone please explain how it can be resolved one day and disappear the next? I do know that rollouts do happen at different times for users and not all at once, but I am unsure how something can change overnight back and forth like this particular issue?


@intersign this has now been resolved for us today (on OneDrive and SharePoint). 
Hopefully it will not revert back like it did with you.


Thanks to the Microsoft team for fixing!

So this issue has appeared again this week. The toolbar was gone on Monday and Tuesday, back working again on Wednesday, then gone again Thursday and Friday 🤷‍:male_sign:


The only difference this time is that the save feature actually still works using the keyboard shortcut! So you can make your changes to you text file, and then use the keyboard shortcut ‘Ctrl + S’ to save. You will not see any notification that it has successfully saved but if you refresh the page the changes should still be there.

Having this same issue today. Are any others?
I don't see a ribbon. I have no idea how to add a table now...

@lc_uxd This issue just surfaced today (March 2023!) in SharePoint online document libraries. We've been using this fantastic feature for several years to edit a few hundred HTML documents in our document library. Earlier this week the "Open in Text Editor" option went missing; only the "Open in Immersive Reader" option is now available. Please please please fix this and bring back this important feature!!

Yes, the Open in (HTML) Text Editor feature went missing in our SharePoint document libraries this week. Please, Microsoft - send a fix!