SharePoint Online: "List cannot be deleted while on hold or retention policy."

Bronze Contributor

I am trying to help a client clean up some very old lists and sites. However, whenever I try to delete anything, I get the message above. I've checked for an eDiscovery site, for classification labels/policies, DLP policies, and am finding nothing. Any ideas?

14 Replies

"List cannot be deleted while on hold or retention policy."

Check the site and list for any hold or retention policies.


  • Site Settings > Site Collection Administration > Content Type Policy Templates.
  • List Settings > Information management policy settings.



Thanks Norman - I have checked those places, which makes this so odd. I'm not sure if these got migrated in from an older version of SharePoint, but I'm finding no way to turn them off.

best response confirmed by VI_Migration (Silver Contributor)

We had the same issue and could not find any hold - retention policies in any place. We had to escalate to Microsoft support and they removed the hold on the back-end. 


I hope this helps.



Are any of the list items on Compliance Hold?

Go to the list - switch to Classic Experience - select the list item - click the ... - select Advanced - Compliance Details. If the Hold Status is On Hold you can remove from hold from this dialog box.


OR a more simple approach:

- Delete the list items first

- Then delete the list object


Hi Kimberley,
Thank you. The delete the Items first and then delete the List object, worked for me.

@Ahmad Petersen Thanks. Yes, go into the Sharepoint List. Delete all the item lines. Then you should be able to delete the whole list.

@Kimberly Roetman 


Hi Kimberly, deleting all the items then the list worked for me. Thank you very much.

@Kelly_Edinger Thanks for posting this.  I just ran into this issue when trying to delete a library.  Thanks to those who suggested deleting the contents then, in this case, the library.

OR a more simple approach:
- Delete the list items first
- Then delete the list object

Worked for me, thanks!
This worked for me! First deleting all items within the list then allowed for me to delete the list itself. Thanks so much!

Had all of the issues the users in this thread were experiencing, even after deleting all list items and checking hold and retention policies. The problem was that I had the list still open on Teams, once I closed it I was able to delete with no issues.


TLDR: Make sure the list isn't open when you want to delete. Sharing if that helps anyone!



Hi @Brittinator - I have never heard of that being an issue before. Thank you for sharing!