Home

SharePoint Online message "Couldn't find a program to open this document".

%3CLINGO-SUB%20id%3D%22lingo-sub-88606%22%20slang%3D%22en-US%22%3ESharePoint%20Online%20message%20%22Couldn't%20find%20a%20program%20to%20open%20this%20document%22.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-88606%22%20slang%3D%22en-US%22%3E%3CP%3EIn%20SharePoint%20Online%20when%20I%20try%20to%20open%20a%20document%20in%20word%2C%20for%20some%20of%20the%20documents%20it%20gives%20error%20message%20as%20shown%20below.%20This%20happens%20only%20on%20a%20handful%20of%20documents.%20Appreciate%20any%20ideas%20to%20troubleshoot%20this%20error.%20Thanks.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20642px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F17408iE68E2357C59FED2A%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22sharepoint%20error.png%22%20title%3D%22sharepoint%20error.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-88606%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-89903%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Online%20message%20%22Couldn't%20find%20a%20program%20to%20open%20this%20document%22.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-89903%22%20slang%3D%22en-US%22%3E%3CP%3EDisabling%20the%20following%20add-ons%20(all%20three%20were%20active)%20solved%20the%20problem%20for%20the%20time%20being.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20938px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F17655i96BCA339CDBB8B97%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Manage%20Add-ons%20(Accelerators).png%22%20title%3D%22Manage%20Add-ons%20(Accelerators).png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-89680%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Online%20message%20%22Couldn't%20find%20a%20program%20to%20open%20this%20document%22.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-89680%22%20slang%3D%22en-US%22%3E%3CP%3EJust%20for%20the%20notes%2C%20following%20are%20my%20add-ons.%20As%20you%20can%20see%20only%20add-ons%20enabled%20are%20the%20Microsoft%20ones.%20I%20haven't%26nbsp%3Byet%20figured%20out%20the%20ones%20causing%20issue.%26nbsp%3BIf%20I%20figure%20out%2C%20I%20will%20post%20it%20here...till%20then%20will%20mostly%20be%20working%20with%20work-arounds%20like%20downloading%20the%20document%20and%20uploading%20back%20etc.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20683px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F17616i1175F981BEF97DC8%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22IE%20Add-Ons.png%22%20title%3D%22IE%20Add-Ons.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-88846%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Online%20message%20%22Couldn't%20find%20a%20program%20to%20open%20this%20document%22.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-88846%22%20slang%3D%22en-US%22%3E%3CP%3E%3CSPAN%3EThanks.%20To%20answer%20your%20questions.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3E(1)%26nbsp%3BIE-11%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3E(2)%26nbsp%3BOffice-2016%3C%2FSPAN%3E%3CBR%20%2F%3E%3CSPAN%3E(3)%20.docx%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EOver%20the%20course%20of%20various%20attempts%2C%20now%20it%20looks%20like%20it%20happens%20when%20I%20run%20IE%20with%20extensions%20off.%20%26nbsp%3BIf%20I%20turn%20the%20extension%20on%2C%20I%20get%20into%20other%20issues%20where%20the%20IE-11%20is%20not%20able%20to%20open%20the%20SharePoint%20site%20itself.%20I%20have%20to%20play%20around%20with%20the%20IE%20add-ons%20and%20turn-on%20and%20off%20as%20needed.%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-88621%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Online%20message%20%22Couldn't%20find%20a%20program%20to%20open%20this%20document%22.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-88621%22%20slang%3D%22en-US%22%3ECould%20you%20please%20provide%20more%20details%20about%20your%20scenario%3F%3CBR%20%2F%3E(1)%20Browser%20you%20are%20using%3CBR%20%2F%3E(2)%20Office%20edition%20installed%20in%20your%20PC%3CBR%20%2F%3E(3)%20If%20this%20is%20happening%20with%20.docx%20files%20or%20.doc%20ones%3C%2FLINGO-BODY%3E
Highlighted
Vivek Jain
Contributor

In SharePoint Online when I try to open a document in word, for some of the documents it gives error message as shown below. This happens only on a handful of documents. Appreciate any ideas to troubleshoot this error. Thanks.

 

sharepoint error.png

 

 

4 Replies
Highlighted
Could you please provide more details about your scenario?
(1) Browser you are using
(2) Office edition installed in your PC
(3) If this is happening with .docx files or .doc ones
Highlighted

Thanks. To answer your questions.

 

(1) IE-11
(2) Office-2016
(3) .docx

 

Over the course of various attempts, now it looks like it happens when I run IE with extensions off.  If I turn the extension on, I get into other issues where the IE-11 is not able to open the SharePoint site itself. I have to play around with the IE add-ons and turn-on and off as needed.

Highlighted

Just for the notes, following are my add-ons. As you can see only add-ons enabled are the Microsoft ones. I haven't yet figured out the ones causing issue. If I figure out, I will post it here...till then will mostly be working with work-arounds like downloading the document and uploading back etc.

 

IE Add-Ons.png

 

Highlighted

Disabling the following add-ons (all three were active) solved the problem for the time being.

 

Manage Add-ons (Accelerators).png

Related Conversations
Make Share function in Edge more useful
HotCakeX in Discussions on
2 Replies
API access to the new Project Online
BenjaminMel in Project on
2 Replies
Issue when accessing enterprise resource pool
cmill262 in Project on
4 Replies
Last Log In Activity on Microsoft Project?
Devryk in Project on
0 Replies