Home

SharePoint Online mega menu links not working with IE11

%3CLINGO-SUB%20id%3D%22lingo-sub-690155%22%20slang%3D%22en-US%22%3ESharePoint%20Online%20mega%20menu%20links%20not%20working%20with%20IE11%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-690155%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20finding%20that%20the%20new%20SharePoint%20mega%20menu%20is%20not%20compatible%20with%20IE11.%26nbsp%3B%20If%20you%20create%20a%20link%20to%20a%20SharePoint%20page%2C%20it%20works%20fine.%26nbsp%3B%20If%20you%20link%20to%20external%20content%2C%20such%20as%20Google%2C%20or%20a%20document%20library%20on%20the%20site%2C%20the%20links%20do%20not%20work.%26nbsp%3B%20When%20you%20hover%20over%20the%20link%2C%20the%20mouse%20pointer%20changes%20to%20the%20hand%20with%20finger.%26nbsp%3B%20However%20the%20link%20does%20not%20work.%26nbsp%3B%20If%20you%20right%20click%20on%20the%20link%20and%20select%20open%2C%20then%20the%20link%20works.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20I%20switch%20over%20to%20the%20hierarchical%20menu%20option%2C%20the%20links%20work%20fine.%26nbsp%3B%20I%20also%20tried%20setting%20the%20compatibility%20view%20settings%20to%20the%20domain%20of%20our%20SharePoint%20tenant.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20else%20experienced%20this%20behavior%3F%26nbsp%3B%20Have%20you%20found%20a%20solution.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-690155%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-699209%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Online%20mega%20menu%20links%20not%20working%20with%20IE11%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-699209%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F270031%22%20target%3D%22_blank%22%3E%40John_Ravas_Schdy%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHi%20John%3C%2FP%3E%3CP%3EWe%26nbsp%3Bcan%20recreate%20the%20problem%20you%20described%20in%20our%20tenant.%3C%2FP%3E%3CP%3EThe%20problem%20initiated%20for%26nbsp%3Bus%20when%20creatng%20mega%20menu%20links%20to%20list%20views%2C%20as%20these%20experience%20exactly%20the%20same%20problem%20in%20IE%2011%20(OK%20in%20Chrome%2FFireFox%2C%20not%20tested%20Edge).%26nbsp%3B%26nbsp%3BHowever%2C%20we%20found%20a%20partial%20workaround%3A%26nbsp%3BSet%20the%20root%2Fparent%20menu%20option%20as%20a%20URL%20to%20one%20of%20the%20list%20views%20instead%20of%20a%20Header.%26nbsp%3BWhen%20you%20then%26nbsp%3Buse%20that%26nbsp%3Broot%20menu%20option%2C%20all%20links%20begin%20to%20work%20including%20list%20views%20AND%20external%20links.%26nbsp%3B%20However%2C%20if%20you%20don't%20click%20the%20root%20menu%20link%20then%20the%20problem%20remains%20(seems%20to%20affect%26nbsp%3Bthat%20browser%20instance).%3C%2FP%3E%3CP%3EOther%20colleagues%20have%20confirmed%20this%20behaviour.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-714481%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Online%20mega%20menu%20links%20not%20working%20with%20IE11%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-714481%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F362027%22%20target%3D%22_blank%22%3E%40Phil_Chadwick%3C%2FA%3E%26nbsp%3Bim%20new%20to%20the%20Sharepoint%20admin%20side%20of%20things.%20Can%20you%20explain%20to%20me%20how%20to%20%22perform%20the%26nbsp%3B%3CSPAN%3Epartial%20workaround%3A%26nbsp%3BSetting%20the%20root%2Fparent%20menu%20option%20as%20a%20URL%20to%20one%20of%20the%20list%20views%20instead%20of%20a%20Header%22%3F%20Any%20help%20will%20be%20appreciated.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3EThanks%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-728166%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Online%20mega%20menu%20links%20not%20working%20with%20IE11%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-728166%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20also%20having%20this%20issue%20in%20our%20tenet.%20I%20couldn't%20get%20the%20workaround%20to%20work%20for%20me.%20Our%20current%20browser%20standard%20in%20our%20enterprise%20is%20still%20IE%2011.%20This%20makes%20Mega%20Menus%20useless%20to%20us.%20A%20fix%20would%20be%20nice.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-728480%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Online%20mega%20menu%20links%20not%20working%20with%20IE11%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-728480%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F270031%22%20target%3D%22_blank%22%3E%40John_Ravas_Schdy%3C%2FA%3E%26nbsp%3BSame%20thing%20here%2C%20Sharepoint%20links%20don't%20work%20in%20IE%2C%20work%20in%20every%20other%20browser.%20Unfortunately%20we%20have%20to%20use%20IE%20for%20certain%20applications.%20Mega%20menu%20would%20be%20great%2C%20if%20it%20worked.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Contributor

We are finding that the new SharePoint mega menu is not compatible with IE11.  If you create a link to a SharePoint page, it works fine.  If you link to external content, such as Google, or a document library on the site, the links do not work.  When you hover over the link, the mouse pointer changes to the hand with finger.  However the link does not work.  If you right click on the link and select open, then the link works.

 

If I switch over to the hierarchical menu option, the links work fine.  I also tried setting the compatibility view settings to the domain of our SharePoint tenant.

 

Has anyone else experienced this behavior?  Have you found a solution.

4 Replies
Highlighted

@John_Ravas_Schdy 

 

Hi John

We can recreate the problem you described in our tenant.

The problem initiated for us when creatng mega menu links to list views, as these experience exactly the same problem in IE 11 (OK in Chrome/FireFox, not tested Edge).  However, we found a partial workaround: Set the root/parent menu option as a URL to one of the list views instead of a Header. When you then use that root menu option, all links begin to work including list views AND external links.  However, if you don't click the root menu link then the problem remains (seems to affect that browser instance).

Other colleagues have confirmed this behaviour.

Highlighted

@Phil_Chadwick im new to the Sharepoint admin side of things. Can you explain to me how to "perform the partial workaround: Setting the root/parent menu option as a URL to one of the list views instead of a Header"? Any help will be appreciated.

 

Thanks

Highlighted

We are also having this issue in our tenet. I couldn't get the workaround to work for me. Our current browser standard in our enterprise is still IE 11. This makes Mega Menus useless to us. A fix would be nice. 

Highlighted

@John_Ravas_Schdy Same thing here, Sharepoint links don't work in IE, work in every other browser. Unfortunately we have to use IE for certain applications. Mega menu would be great, if it worked.

Related Conversations