SharePoint Online: Can't add internet search engine as search source

%3CLINGO-SUB%20id%3D%22lingo-sub-1060009%22%20slang%3D%22en-US%22%3ESharePoint%20Online%3A%20Can't%20add%20internet%20search%20engine%20as%20search%20source%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1060009%22%20slang%3D%22en-US%22%3E%3CP%3EHi.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20trying%20to%20set%20up%20or%20SharePoint%20Online%20tenant%20to%20include%20external%20search%20engines%20in%20its%20searches.%20For%20testing%2C%20I'm%20trying%20to%20use%20bing.com%20as%20search%20source%2C%20but%20for%20some%20reason%20I%20can't%20seem%20to%20get%20it%20working%20properly.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20setup%20was%20done%20like%20this%3A%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3ENavigate%20to%20https%3A%2F%2F%3CTENANT%3E-admin.sharepoint.com%2F_layouts%2F15%2FManageResultSources.aspx%3Flevel%3Dtenant%3C%2FTENANT%3E%3C%2FLI%3E%3CLI%3EClick%20New%20Result%20Source%3C%2FLI%3E%3CLI%3ESettings%20(picked%20the%20most%20important%20ones)%3COL%3E%3CLI%3E%22Query%20Transform%22%3A%20%22%7BsearchTerms%7D%22%3C%2FLI%3E%3CLI%3E%22Source%20Url%22%3A%20%22%3CA%20href%3D%22https%3A%2F%2Fwww.bing.com%2Fsearch%3Fq%3D%7BsearchTerms%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fwww.bing.com%2Fsearch%3Fq%3D%7BsearchTerms%3C%2FA%3E%7D%22%3C%2FLI%3E%3C%2FOL%3E%3C%2FLI%3E%3C%2FOL%3E%3CP%3EWhen%20navigating%20back%20to%26nbsp%3Bhttps%3A%2F%2F%3CTENANT%3E-admin.sharepoint.com%2F_layouts%2F15%2FManageResultSources.aspx%3Flevel%3Dtenant%2C%20selecting%20my%20new%20source%20and%20clicking%20%22Test%20Source%22%20in%20the%20dropdown%20menu%20results%20in%20%22Internal%20Server%20Error%22%20in%20the%20%22Test%20details%22%20box.%26nbsp%3B%3C%2FTENANT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EApparently%20I'm%20doing%20something%20wrong%2C%20but%20I%20can't%20spot%20the%20error.%26nbsp%3B%3C%2FP%3E%3CP%3EHave%20others%20successfully%20set%20up%20external%20search%20engine%20sources%2C%20and%20would%20like%20to%20share%20some%20insights%20on%20how%20to%20get%20this%20thing%20working%3F%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1060009%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Contributor

Hi.

 

I'm trying to set up or SharePoint Online tenant to include external search engines in its searches. For testing, I'm trying to use bing.com as search source, but for some reason I can't seem to get it working properly. 

 

The setup was done like this: 

  1. Navigate to https://<tenant>-admin.sharepoint.com/_layouts/15/ManageResultSources.aspx?level=tenant
  2. Click New Result Source
  3. Settings (picked the most important ones)
    1. "Query Transform": "{searchTerms}"
    2. "Source Url": "https://www.bing.com/search?q={searchTerms}"

When navigating back to https://<tenant>-admin.sharepoint.com/_layouts/15/ManageResultSources.aspx?level=tenant, selecting my new source and clicking "Test Source" in the dropdown menu results in "Internal Server Error" in the "Test details" box. 

 

Apparently I'm doing something wrong, but I can't spot the error. 

Have others successfully set up external search engine sources, and would like to share some insights on how to get this thing working? 

 

 

0 Replies