Sharepoint News from selected pages not working

Highlighted
New Contributor

I am currently building a Sharepoint intranet for a customer and I am having some quite annoying issues with the news web part, it will only show the news from the site the web part is on. As well as an old post made a month ago. Currently we got 2 communication pages, one called 'intra' and one called 'HR'. On one of the pages we are going to have a news feed that fetched the news from both sites. 

 

For demonstration purposes I have made a news web part on the page called 'intra' and set it to only fetch news from the 'HR' site. I have made 5 posts with 'HR' news as you can se below.

 

Screenshot 2019-11-19 at 14.51.18.png

 

As you can see on the screenshot below, only 1 of those 5 news posts I made shows, I have noticed that it only want to show the last created news post from 'HR'. Some time not even one of the news posts. The web part is set to 'list' and to show 8 news maximum. 

Screenshot 2019-11-19 at 14.50.52.png

So, no matter what I am doing it will at best only show the latest published news post from 'HR' together with another older post that I have no idea why works. 

 

Does anyone got any solution how to solve this issue, been spending several days now trying to solve the issue with no luck. 

 

Any input or suggestions on how to fix this problem are welcome.

2 Replies
Highlighted

@ValentinM I deleted all 5 posts and made 2 new news posts, both showed up after around 20 minutes in the newsfeed. But when I made the 3rd news post, that one also came up in the feed, but it replaced one of the other 2 posts...

Highlighted

@ValentinM 

Hello! You've posted your question in the Community Discussion space, which is intended for discussion around the Tech Community website itself, not product questions. I'm moving your question to the SharePoint space - please post SharePoint questions here in the future.