SharePoint modern, new news page breaks news webparts unexpectedretryableerror

Frequent Contributor

Hi Everyone,

For about 5 days I'm getting the following error here in New Zealand when creating new News pages on a Modern SharePoint site we use as our intranet.


Steps I do which sometimes cause this issue

Visit home page of Modern Intranet

- it has a list of news items bottom left and a news carosel top centre

Click "New news post" from the grey actions bar

Create a new news modern page

Add content, images etc

Publish the page, it works fine and shows no errors




On the home page the news carosel shows the error attached

"Something went wrong" Error: UnexpectedRetryableError CallStack:


If I go to the news.aspx All News listing the same eror is displayed.


If I edit the new News page and remove all content, the same error still shows for the home page news carosel. If I delete the new News page. The errors go away.




Sometimes creating a new news item doesn't cause this issue.


Your suggestions and ideas would be greatly accepted :)


Many thanks


Something went wrong

5 Replies

@Dorje McKinnon I am now getting the same error when I change the news source in my news web part to 'Select Sites' 

Hi@hannahmayes and @Dorje McKinnon 

I recommend you log a support ticket with Microsoft for this one (you'll need to have appropriate 365 Admin centre privileges to do this so you may need support from colleagues if you don't). 

I'm not sure if you're using new Home site or if issue is happening on a standard Communication site?  I'm not seeing this error in my tenant (Australia), but I'm not yet using the new Home site.

Over the last couple of years I have seen functionality in News web part break following new features being released. After raising a support ticket the techs were able to replicate and resolve problem.

In your support request, be as clear as possible about the problem and include screenshots/detail steps.

best response confirmed by Dorje McKinnon (Frequent Contributor)

@Jenny Bruce  and @hannahmayes  and @Lee Stevens 

A month after this post I posted again, with more details and to try and drum up more interest in my problem.
Eventually that new thread lead to me figuring out what a solution. See the last post of the following thread:

The problem was being caused in our case by "Two Search Schema managed properties with the same names or alias."


I hope this helps

Thank you for the update. I have logged a support ticket. At first glance I don't think your solution applies in my case. However there are distinct similarities so I will continue to pursue this line of investigation. Many thanks.

Thank you @Jenny Bruce and @Dorje McKinnon 


I followed Dorje's and Mike Lees suggestions, however both crawled properties were present and there was no new managed property using “AuthorOWSUSER” as an alias.


So I logged a support ticket and received a same day response, impressive!  They ran a backend sync and the problem resolved.


Again, thank you for your replies as I wouldn't have resolved it as quickly without your suggestions.