SharePoint Modern Doc Library Web Part - Won't display other views

%3CLINGO-SUB%20id%3D%22lingo-sub-92996%22%20slang%3D%22en-US%22%3ESharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-92996%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20been%20using%20the%20new%20Modern%20Document%20Library%20web%20part%20for%20a%20few%20weeks%20now%20without%20issue.%20Suddenly%20yesterday%20around%20noon%2C%20any%20instances%20of%20the%20webpart%20I%20had%20reverted%20to%20the%20default%20view%20of%20the%20Library%20and%20I%20could%20never%20get%20it%20to%20go%20back%20to%20a%20non-default%20view.%20If%20I%20change%20which%20view%20is%20default%2C%20they'll%20all%20show%20the%20new%20default.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20even%20tried%20with%20entirely%20different%20libraries%20on%20different%20sites%20thinking%20I%20might%20have%20messed%20something%20up%20with%20that%20library%2C%20but%20with%20the%20same%20results.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIs%20anyone%20else%20having%20this%20issue%3F%20Anyone%20have%20an%20idea%20of%20how%20to%20fix%20it%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-92996%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDocument%20Library%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Emodern%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EViews%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Eweb%20part%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-288394%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-288394%22%20slang%3D%22en-US%22%3E%3CP%3EGood%20day%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CBLOCKQUOTE%3E%3CHR%20%2F%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F32813%22%20target%3D%22_blank%22%3E%40Julie%20Sanders%3C%2FA%3E%26nbsp%3Bwrote%3A%3CBR%20%2F%3E%3CP%3ESame%20issue.%20Microsoft%20-%20any%20update%3F%26nbsp%3B%3C%2FP%3E%3CHR%20%2F%3E%3C%2FBLOCKQUOTE%3E%3CP%3E%3CBR%20%2F%3E%3CBR%20%2F%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-284182%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-284182%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20issue.%20Microsoft%20-%20any%20update%3F%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-230101%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-230101%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20Nigel%20-%20Good%20call%2C%20but%20the%20same%20problem%20started%20to%20occur%20in%20my%20tenant%20as%20well%2C%20about%2030%20minutes%20after%20I%20posted%20my%20prior%20reply.%26nbsp%3B%20My%20tenant%20is%20in%20Targeted%20Release%20and%20the%20customer's%20tenant%20is%20not.%26nbsp%3B%20So%20its%20not%20related%20to%20that.%26nbsp%3B%20I've%20got%20a%20ticket%20open%20with%20MS%20Support.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESeems%20like%20this%20is%20a%20really%20broad%20problem...%20I'm%20surprised%20there%20aren't%20more%20people%20reporting%20this%20right%20now.%26nbsp%3B%20Not%20sure%20when%20it%20started%2C%20as%20I%20just%20started%20to%20actually%26nbsp%3Bconfigure%20these%20new%20sites.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-230033%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-230033%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20Tom%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIS%20your%20Tenancy%20in%20the%20fast%20ring%20%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIf%20so%20that%20could%20be%20the%20answer%20to%20what%20you%20have%20experienced.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENigel%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-229528%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-229528%22%20slang%3D%22en-US%22%3E%3CP%3EI%20just%20suddenly%20got%20the%20same%20issue%20myself%20(with%20Document%20Library%20web%20part)%2C%20in%20a%20customer's%20tenant.%26nbsp%3B%20I%20tried%20to%20reproduce%20the%20same%20problem%20in%20my%20tenant%26nbsp%3Band%20it%20worked%20properly.%26nbsp%3B%20Anyone%20else%20seeing%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-226154%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-226154%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20issue%20just%20popped%20up%20for%20me%20but%20with%20the%20List%20Web%20Part.%20Keeps%20switching%20back%20to%20the%20Default%20View%20anytime%20I%20refresh%20the%20page.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-224939%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-224939%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20All%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20similar%26nbsp%3Bissue%2C%20inclined%20to%20revert%20back%20to%20the%20classical%20mode.%3C%2FP%3E%3CP%3EHopefully%2C%20MS%20will%20fix%20soon.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3EPavel%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-224387%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-224387%22%20slang%3D%22en-US%22%3E%3CP%3EGood%20Day%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20facing%20the%20same%20issue%2C%20I%20have%20been%20using%20the%20new%20Modern%20Document%20Library%20web%20part%20for%20more%20than%20a%20month%20without%20any%20issue%2C%20then%20unexpectedly%20the%20page%20has%20added%20the%20web%20part%20is%20keep%20loading%20then%20shown%20all%20documents%20in%20the%20document%20library%20'not%20filtered'%2C%20sometimes%20not%20show%20the%20document%20view%20name%20on%20the%20view%20list%2C%20and%20back%20to%20the%20default%20view%20and%20shows%20shown%20all%20document%2C%26nbsp%3B%3C%2FP%3E%3CP%3EHope%20the%20issue%20gets%20resolved%20soon...%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBest%20Regards%3C%2FP%3E%3CP%3EAlaa%20Balbisi%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-224189%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-224189%22%20slang%3D%22en-US%22%3E%3CP%3EYes%2C%20having%20the%20same%20issue.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-224070%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-224070%22%20slang%3D%22en-US%22%3E%3CP%3EI've%20just%20had%20this%20issue%20pop%20up%20again%2C%20but%20only%20for%20one%20user.%20She%20seems%20to%20have%20a%20slightly%20different%20version%20of%20the%20document%20library%20webpart%20that%20allows%20you%20to%20change%20view%20within%20the%20page%20-%20is%20this%20a%20new%20version%3F%20It's%20odd%20because%20all%20users%20in%20our%20environment%20are%20set%20to%20the%20same%20release%20schedule%2C%20but%20so%20far%20I%20only%20have%20one%20user%20with%20this%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-222929%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-222929%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20this%20issue%20and%20it%20started%20a%20couple%20of%20days%20ago.%26nbsp%3B%20Anyone%20know%20how%20we%20can%20resolve%20this%20issue%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-222279%22%20slang%3D%22en-US%22%3ERe%3A%20Working%20correctly%20again%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-222279%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20issue%20just%20turned%20on%20for%20me%20this%20week%20on%20multiples%20sites.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-153455%22%20slang%3D%22en-US%22%3ERe%3A%20Working%20correctly%20again%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-153455%22%20slang%3D%22en-US%22%3E%3CP%3EHi%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EThis%20seems%20to%20be%20working%20for%20me.%26nbsp%3B%20I%20am%20in%20Western%20Europe.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ERegards%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ENigel%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-153440%22%20slang%3D%22en-US%22%3ERe%3A%20Working%20correctly%20again%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-153440%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20the%20same%20issue%20on%20my%20site.%20Still%20a%20problem.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-139308%22%20slang%3D%22en-US%22%3ERe%3A%20Working%20correctly%20again%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-139308%22%20slang%3D%22en-US%22%3EThis%20actually%20still%20seems%20to%20be%20an%20issue.%20I%20add%20the%20Document%20Library%20(Preview)%20web%20part%2C%20select%20a%20document%20library%20and%20a%20view%20that%20is%20not%20the%20default%20and%20get%20the%20following%3A%20%3CBR%20%2F%3E%22The%20specified%20list%20is%20invalid%3CBR%20%2F%3EThe%20specified%20list%20might%20have%20been%20deleted%20or%20you%20might%20not%20have%20permission%20to%20view%20it.%20Contact%20the%20site%20owner%20for%20more%20information.%22%3CBR%20%2F%3E%3CBR%20%2F%3EAll%20default%20views%20work%20without%20issue.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-97152%22%20slang%3D%22en-US%22%3ERe%3A%20Working%20correctly%20again%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-97152%22%20slang%3D%22en-US%22%3E%3CP%3ELucky%20you%2C%20Steve%2C%20it's%20not%20working%20for%20me.%20Response%20to%20my%20ticket%20from%20Microsoft%20today%20is%20that%20this%20is%20an%20issue%20across%20o365%20and%3A%3C%2FP%3E%3CP%3EThe%20feedback%20that%20we%20currently%20have%20from%20the%20Product%20Group%20is%20that%20a%20fix%20has%20already%20been%20created%20and%20is%20currently%20being%20verified%20that%20it%20is%20working%20as%20expected.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96952%22%20slang%3D%22en-US%22%3EWorking%20correctly%20again%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96952%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20Document%20Library%20web%20part%20appears%20to%20be%20working%20correctly%20for%20me%20again.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20once%20again%20save%20the%20Document%20Library%20web%20part%20with%20non-default%20views.%20Fortunately%20my%20sites%20aren't%20live%20to%20the%20general%20population%20yet.%20I'll%20keep%20an%20eye%20on%20these%20over%20the%20next%20couple%20weeks%20to%20see%20what%20happens%2C%20but%20it's%20going%20to%20take%20a%20while%20to%20build%20trust%20in%20this%20web%20part%20again.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHopefully%20it%20%3CSTRONG%3Ekeeps%3C%2FSTRONG%3E%26nbsp%3Bworking%20correctly%20this%20time.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96595%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96595%22%20slang%3D%22en-US%22%3ELets%20hope%20that%20you%20get%20some%20answers!%20If%20you%20do%2C%20please%20post%20them%20here.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96472%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96472%22%20slang%3D%22en-US%22%3E%3CP%3EThanks%20for%20the%20idea%2C%20Paul%2C%20but%20this%20does%20not%20solve%20the%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThere%20are%20plenty%20of%20cases%20where%20you%20do%20not%20want%20the%20view%20used%20in%20your%20Document%20Library%20web%20part%20to%20be%20the%20Default%20View%20of%20the%20library%20-%20especially%20in%20cases%20where%20you%20are%20using%20the%20web%20part%20across%20multiple%20pages%20with%20different%20views%20on%20each%20to%20display%20different%20sets%20of%20documents%20from%20the%20library.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20error%20is%20not%20with%20setting%20a%20default%20view%20for%20the%20library%20-%20the%20error%20is%20with%20the%20web%20part%20not%20saving%20your%20selection%20of%20which%20view%20to%20use.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96445%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96445%22%20slang%3D%22en-US%22%3E%3CP%3Efor%20work%20arround%20have%20you%20guys%20tried%20this%3F%3C%2FP%3E%3CP%3Ein%20the%20gif.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-96430%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-96430%22%20slang%3D%22en-US%22%3E%3CP%3ESame%20for%20us.%20I've%20raised%20a%20ticket%20which%20will%20hopefully%20be%20getting%20looked%20into%20tomorrow.%20REG%3A117081516188713%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-95733%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-95733%22%20slang%3D%22en-US%22%3E%3CP%3EI'm%20having%20the%20same%20problem.%20The%20web%20part%20is%20only%20showing%20the%20document%20librarys%20default%20view.%20Does%20anyone%20have%20any%20solutions%20or%20updates%20on%20what%20may%20be%20causing%20the%20problem%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-93788%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-93788%22%20slang%3D%22en-US%22%3E%3CP%3EAs%20far%20as%20I%20could%20tell%2C%20nothing%20that%20I%20did%20seemed%20to%20have%20any%20effect%20on%20it.%20The%20problem%20seemed%20to%20resolve%20itself%20after%20~24%20hours.%20My%20thought%20is%20that%20it%20was%20something%20in%20Microsoft's%20side%20of%20things.%20Unfortunately%20when%20I%20checked%20my%20site%20this%20morning%2C%20the%20issue%20seems%20to%20have%20returned%2C%20and%20I%20certainly%20didn't%20do%20anything%20over%20the%20weekend%20that%20would've%20caused%20the%20issue.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20is%20a%20very%20frustrating%20problem.%20I%20hope%20they%20resolve%20it%20quickly%20or%20I%20just%20won't%20be%20able%20to%20rely%20on%20this%20web%20part.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-93679%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-93679%22%20slang%3D%22en-US%22%3E%3CP%3EMy%20sites%20are%20now%20having%20this%20issue.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20was%20doing%20a%20demo%20to%20show%20how%20you%20could%20use%20meta%20data%20to%20move%20information%20between%20different%20views.%20And%20I%20just%20couldn't%20get%20it%20to%20work.%20Something%20I%20used%20alot%20with%20the%20old%20on-prem%20SharePoint.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EStrange%20-%20how%20exactly%20did%20you%20fix%20it%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-93135%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-93135%22%20slang%3D%22en-US%22%3E%3CP%3EThis%20issue%20seems%20to%20have%20resolved%20itself%20-%20my%20Document%20Library%20web%20parts%20are%20once%20again%20displaying%20the%20correct%20views%20on%20the%20page.%20I%20don't%20think%20I%20changed%20anything%20on%20my%20end%20that%20would%20have%20affected%20it%2C%20so%20I'm%20guessing%20it%20was%20something%20on%20Microsoft's%20end.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI'm%20happy%20it's%20resolved%2C%20but%20annoyed%20with%20the%20lack%20of%20clarity%20about%20what%20was%20happening.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-93114%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Modern%20Doc%20Library%20Web%20Part%20-%20Won't%20display%20other%20views%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-93114%22%20slang%3D%22en-US%22%3E%3CP%3ETwo%20users%20contacted%20me%20about%20some%20weird%20display%20problems%20with%20the%20modern%20experience.%20%26nbsp%3BThe%20home%20page%20didn't%20load%20and%20instead%20they%20saw%20the%20site%20pages%20library.%20%26nbsp%3BThe%20edit%20experience%20broke.%20%26nbsp%3BSwitching%20to%20the%20Classic%20experience%20solved%20their%20problems.%20%26nbsp%3BI%20will%20work%20on%20reproducing%20the%20problem%20so%20I%20can%20provide%20better%20docs.%20%26nbsp%3BI%20am%20sorry%20I%20don't%20have%20a%20clear%20descripton%20and%20screenshots.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

I have been using the new Modern Document Library web part for a few weeks now without issue. Suddenly yesterday around noon, any instances of the webpart I had reverted to the default view of the Library and I could never get it to go back to a non-default view. If I change which view is default, they'll all show the new default.

 

I've even tried with entirely different libraries on different sites thinking I might have messed something up with that library, but with the same results.

 

Is anyone else having this issue? Anyone have an idea of how to fix it?

 

Thanks!

27 Replies

Two users contacted me about some weird display problems with the modern experience.  The home page didn't load and instead they saw the site pages library.  The edit experience broke.  Switching to the Classic experience solved their problems.  I will work on reproducing the problem so I can provide better docs.  I am sorry I don't have a clear descripton and screenshots.

This issue seems to have resolved itself - my Document Library web parts are once again displaying the correct views on the page. I don't think I changed anything on my end that would have affected it, so I'm guessing it was something on Microsoft's end.

 

I'm happy it's resolved, but annoyed with the lack of clarity about what was happening.

My sites are now having this issue. 

 

I was doing a demo to show how you could use meta data to move information between different views. And I just couldn't get it to work. Something I used alot with the old on-prem SharePoint.

 

Strange - how exactly did you fix it?

 

 

As far as I could tell, nothing that I did seemed to have any effect on it. The problem seemed to resolve itself after ~24 hours. My thought is that it was something in Microsoft's side of things. Unfortunately when I checked my site this morning, the issue seems to have returned, and I certainly didn't do anything over the weekend that would've caused the issue.

 

This is a very frustrating problem. I hope they resolve it quickly or I just won't be able to rely on this web part.

I'm having the same problem. The web part is only showing the document librarys default view. Does anyone have any solutions or updates on what may be causing the problem?

Same for us. I've raised a ticket which will hopefully be getting looked into tomorrow. REG:117081516188713

for work arround have you guys tried this?

in the gif.

Thanks for the idea, Paul, but this does not solve the issue.

 

There are plenty of cases where you do not want the view used in your Document Library web part to be the Default View of the library - especially in cases where you are using the web part across multiple pages with different views on each to display different sets of documents from the library.

 

The error is not with setting a default view for the library - the error is with the web part not saving your selection of which view to use.

Lets hope that you get some answers! If you do, please post them here.

The Document Library web part appears to be working correctly for me again.

 

I can once again save the Document Library web part with non-default views. Fortunately my sites aren't live to the general population yet. I'll keep an eye on these over the next couple weeks to see what happens, but it's going to take a while to build trust in this web part again.

 

Hopefully it keeps working correctly this time.

Lucky you, Steve, it's not working for me. Response to my ticket from Microsoft today is that this is an issue across o365 and:

The feedback that we currently have from the Product Group is that a fix has already been created and is currently being verified that it is working as expected.

This actually still seems to be an issue. I add the Document Library (Preview) web part, select a document library and a view that is not the default and get the following:
"The specified list is invalid
The specified list might have been deleted or you might not have permission to view it. Contact the site owner for more information."

All default views work without issue.

I have the same issue on my site. Still a problem.

Hi

 

This seems to be working for me.  I am in Western Europe.

 

Regards

 

Nigel

This issue just turned on for me this week on multiples sites.

I'm having this issue and it started a couple of days ago.  Anyone know how we can resolve this issue?

I've just had this issue pop up again, but only for one user. She seems to have a slightly different version of the document library webpart that allows you to change view within the page - is this a new version? It's odd because all users in our environment are set to the same release schedule, but so far I only have one user with this issue.

Yes, having the same issue. 

Good Day,

 

I'm facing the same issue, I have been using the new Modern Document Library web part for more than a month without any issue, then unexpectedly the page has added the web part is keep loading then shown all documents in the document library 'not filtered', sometimes not show the document view name on the view list, and back to the default view and shows shown all document, 

Hope the issue gets resolved soon...

 

Best Regards

Alaa Balbisi