SharePoint Migration Tool just updated to - Now migrations fail - item does not exist

New Contributor

Currently using SharePoint Migration Tool to help migrate from 2016 Onprem to SharePoint Online

We have been using version for several months with no problems.

Tool automatically updated to version yesterday and now migration of all items fail with:

Message:Item does not exist. It may have been deleted by another user.


Even though the item does exist and this site has been migrated sucessfully before. 

Tried to uninstall tool and reinstall old version but the installer always installs from an online source.

How do we get the old version or get this fixed?

3 Replies

@Steve_Pogue I am having the same issue as well. Do we know what was changed in the new update?

@nd202001 I am not sure what changed or why it worked before but here is the workaround:  The error is related to the recycle bin.  I started over by deleting the site then emptying the recyclebin and the site collection recyclebin.

@Steve_Pogue Interesting, I don't have anything in either recycle bins. I would delete the site with the migrated content, unfortunately there is other content on the site that I migrated recently and didn't want to lose it.