SharePoint Migration Tool is not working as expected.

%3CLINGO-SUB%20id%3D%22lingo-sub-660548%22%20slang%3D%22en-US%22%3ESharePoint%20Migration%20Tool%20is%20not%20working%20as%20expected.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-660548%22%20slang%3D%22en-US%22%3E%3CP%3EI%20was%20testing%26nbsp%3BSharePoint%20Migration%20Tool%20and%20could%20migrate%20few%20lists%20and%20libraries%20without%20issue%2C%20it%20was%20considerable%20time%20though.%20But%20after%20the%20version%20got%20updated%20to%203.1.110.1%2C%20situation%20got%20bad.%20For%20a%20list%20with%202%20items%20it%20took%2030%20mins%20and%20when%20I%20try%20library%20with%20around%2060%20items%2C%20the%20scanning%20step%20never%20progressed%2C%20Its%20been%20running%20for%20more%20than%2012%20hrs%20but%20no%20progress.%3CBR%20%2F%3E%3CBR%20%2F%3EIs%20anyone%20able%20to%20migrate%20contents%20with%20the%20new%20version%3F%3C%2FP%3E%3CP%3E%3CBR%20%2F%3EFollowing%20error%20is%20continuously%20being%20logged%20in%20logs%3A%3CBR%20%2F%3E%3CBR%20%2F%3E%3CEM%3ETaxonomy%20migration%3A%20error%20retrieving%20Term%20Owner%20%3A%20%3CUSERID%3Einformation%20Microsoft.SharePoint.MigrationTool.MigrationLib.SharePoint.MigSPServerException%3A%20Server%20Issue%20when%20doing%20SP%20Query%20---%26gt%3B%20Microsoft.SharePoint.Client.ServerException%3A%20The%20specified%20user%20%3CUSERID%3E%20could%20not%20be%20found.%3C%2FUSERID%3E%3C%2FUSERID%3E%3C%2FEM%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-660548%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-660695%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Migration%20Tool%20is%20not%20working%20as%20expected.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-660695%22%20slang%3D%22en-US%22%3E%3CP%3EHello%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F181427%22%20target%3D%22_blank%22%3E%40Asif%20Shaik%3C%2FA%3E%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20not%20experienced%20the%20same%20error%20but%20the%20error%20message%20does%20seem%20related%20to%20a%20missing%20user.%20Have%20you%20reviewed%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepointmigration%2Fcreate-a-user-mapping-file-for-data-content-migration%22%20target%3D%22_self%22%20rel%3D%22noopener%20noreferrer%22%3ECreate%20a%20user%20mapping%20file%20for%20data%20content%20migration%3C%2FA%3E%20site%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20hope%20this%20helps.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ENorm%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-666527%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Migration%20Tool%20is%20not%20working%20as%20expected.%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-666527%22%20slang%3D%22en-US%22%3E%3CP%3EHello%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F111382%22%20target%3D%22_blank%22%3E%40Norman%20Young%3C%2FA%3E%2C%20Thank%20you%20for%20the%20reply.%3C%2FP%3E%3CP%3EI%20don't%20have%20any%20user%20mapping%20file%2C%20but%26nbsp%3B%3CSPAN%3Ea%20default%20user%20mapping%20file%20will%20be%20used%20by%20tool%20if%20nothing%20is%20provided.%20I%20am%20wondering%2C%20where%20do%20we%20get%20user%20mapping%20details%3F%20And%20what%20is%20the%20importance%20of%20user%20user%20mapping%20in%20general%3F%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnd%20migration%20was%20happening%20as%20expected%20with%20older%20%26nbsp%3Bversion.%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

I was testing SharePoint Migration Tool and could migrate few lists and libraries without issue, it was considerable time though. But after the version got updated to 3.1.110.1, situation got bad. For a list with 2 items it took 30 mins and when I try library with around 60 items, the scanning step never progressed, Its been running for more than 12 hrs but no progress.

Is anyone able to migrate contents with the new version?


Following error is continuously being logged in logs:

Taxonomy migration: error retrieving Term Owner : <userid>information Microsoft.SharePoint.MigrationTool.MigrationLib.SharePoint.MigSPServerException: Server Issue when doing SP Query ---> Microsoft.SharePoint.Client.ServerException: The specified user <userid> could not be found.

2 Replies

Hello @Asif Shaik,

 

I have not experienced the same error but the error message does seem related to a missing user. Have you reviewed Create a user mapping file for data content migration site?

 

I hope this helps.

 

Norm

Hello @Norman Young, Thank you for the reply.

I don't have any user mapping file, but a default user mapping file will be used by tool if nothing is provided. I am wondering, where do we get user mapping details? And what is the importance of user user mapping in general?

 

And migration was happening as expected with older  version.