SOLVED

Sharepoint Metadata - New default value is not being used

Contributor

I changed the default value for a column in a document library but when I create a new file it still defaults to the old default value. Is there something I can do to force it to notice the new default value?New document is using wrong default value "10500.01"New document is using wrong default value "10500.01"Choices for metadata and default value "OT500.01"Choices for metadata and default value "OT500.01"

11 Replies

Has no one else had this issue? Do I have to reboot my sharepoint site somehow?

Microsoft tech support has suggested that I re-index my document library. https://support.office.com/en-us/article/Manually-request-crawling-and-re-indexing-of-a-site-a-libra...

I have done it but it has not helped so far.

best response confirmed by Reuben Helder (Contributor)
Solution

I contacted Microsoft support and they said:

Also check it in Library Settings > General Settings > Column default value settings.
Click on desired Column name and set Use this default value

 

So apparently you need to change the "Default Value" in two places. In the general library settings and in the specific column settings.

Hi Reuben,

 

I'm still having the same issue - it keeps reverting to an old setting even after updating the default value in both locations. I've even tried deleting the column and recreating it using the same column name... and it still reverts back to the old default values.

 

Have you come across any other potential solutions?

 

Thanks,
Alex

Have you tried changing the Default in both locations?

 

 

Apparently you need to change the "Default Value" in two places. In the general library settings and in the specific column settings.

 

In other news I've started using LookUp Site Columns instead which are easier to manage but sadly you can't set default values on them which is very annoying.

Fella's, I also am having this issue. I have changed the default value in both places but the forms must be reading the data from somewhere else. Any new discoveries?

Thanks,
Wiley Winter

I also see this problem - but with a little twist:

 

If I use the "New" button to create the document, then I see this problem - the wrong default is used.

 

However, if I drag a document into the library, the correct default is used. It also respects different defaults on different subfolders.

 

So as far as I can see, the setup of my system is correct, and the problem is in the logic behind the "New" button.

 

Is this in accordance with what you guys see?

 

Regards

Leif

Seems like the old value is being picked up from the template assigned to the Content Type. You have to edit the template.docx associated with the Content Type and set the default value in there, bringing the total number of places you have to change it to THREE :(

Thanks. I face same issue with SP Online today and your solution works perfectly :)
Hi Leif, I have exactly the same issue, in SP 2019, did you make it work? As I can notice, when klick on new and the open with program (ex Word) then works, but not working when only create new from browser.

@Reuben Helder 

Check your workflow(s). They may be still pulling the old default value. Also note, that I had to specify the value for it to pull. When I cleared the old default value and left it blank, it STILL pulled in the old default value. ¯\_(ツ)_/¯ In order for it to stop pulling in the old default value, I had to specifically set the value I wanted to show up as the default in the workflow.

 

Hope this helps.