Sharepoint logo not changing

Copper Contributor

Hey everyone,


Like many other users, I can't seem to change the logo on my SPO site.


I created this site via Team -> go to Sharepoint site.


I've tried the many solutions:

  • change the look
  • change logo in site information
  • replaced logo file with __siteIcon__.png in site assets, gets automatically re-written by system


I get this error when I try to upload the picture via site information. Does anyone recognize how to adjust this setting?



24 Replies

Hello @MitchMicro2020 

Try to change the site theme, close the tab or browser, then open SharePoint site go to Site information and change the logo.

This resolved my issue.



Hi @Alireza Rahimifarid,


I've had no success, since the creation of the group, changing the logo while changing the theme as well.


Thanks for the reply!



@MitchMicro2020 take a look at


"Make sure the O365 group property "HiddenFromAddressListsEnabled" is not set to True. Exchange or Global administrators should use Set-UnifiedGroup to set HiddenFromAddressListsEnabled to False."


Teams for example sets this to True by default on sites created thru teams 

@Bruno Aleixo Thanks for the reply! I'll give this a try and let you know if it works.



This sounds like you are hitting a cache issue so try hitting ctrl-F5 in the browser. If that doesn't work, make sure that the new logo image is properly checked in and published (assuming it is in the SharePoint site and not in /_layouts/). ... That will bypass almost all caching.

Try clearing the broswer memory. I closed the browser I was working in (Edge), opened the Sharepoint Site in a different browser (Chrome) and then the logo changed successfully.  I have had this happen a few times and I think the last time I resolved it was by clearing the browser memory.

Did you solve? I am stuck with same today and solutions below do nothing. I have cleared the cache and tried multiple browsers and just waited. MS error says "We experienced a problem updating the icon. Please try again in a few minutes." I have this happen periodically.
This is happening in our tenant as well. This was similar bug we had 1-2 years ago that took a month or two to fix. I tried every day for past week with different browsers and still same issue, notice in Site Assets the site logo is getting overwritten constantly. Welcome back the bug :(
This is happening again in our tenant as well. It occurred about 1-2 years ago and took a few months to get fixed. I tried every day for a week now and in 3 different browsers. Notice in the Site Assets library, the site icon files are getting updated every hour/ several times a day. I'll have to put in another ticket with MS.
In the end I was able to fix. I had to rename my site icons with MS's standard for the png in the site asset folder and then overwrite it manually. I didn't work for all sites, but then I found that if deleted both jpg and png icon files MS would automatically regenerate these files with lettered blank icon files. They I could overwrite just the png (name with two underscores on each side so it matches and asked to overwrite)....ugh...but fixed.
I agree with Heather, rename your logo to "__rectSitelogo__Transparent icon.png" and upload to SiteAssets , over-write the generated logo in Site Assets. NOTE : those are double under-scores.
Hi All, I have been experiencing this recently and more so today. I created a team site in SharePoint, then updated the logos, then added it to MS teams. Within seconds the logos reverted. Has anyone on this thread been able to work with Microsoft to resolve the issue instead of using the manual reload of the logo files?
So far this has only happened with teams. I have added from both sides - overwritten files in SharePoint then teams...even dropped in outlook desktop popups. Not fix for a few. I haven't fixed a handful, but because it is only happening with a few I decided it is some setting when the site is provisioned. Maybe scripting turned off?

@Mike Dockray 


This corrected my problem is well.  This is very frustrating and buggy. Thanks Mike.

So I have recently learned that if you have a mix of Sharepoint Modern and Sharepoint Classic view pages, changing the site logo under the classic page will not proliferate to the modern page.  But the reverse will cascade the change through all pages.


So what I mean is, the site logo will not change unless you make the change as follows:


Gear-->Change the look-->Header-->scroll down-->Site logo-->upload here.


If you attempt to change from here:

Site Settings-->Title, description, and logo-->Insert Logo  


and that is a Sharepoint classic themed page, it will not change.


Image type does not matter, for example, I am using a .gif and it is working fine.






I had the same issue today.
Check if your Site has a Group (Teams or Outlook) connected, if it is the case, first change the icon of the group.
There are many explanation on the web on how to do it but basically, just go in Outlook web, under "groups" click on your group name (make sure to be a member of it), and at then end, at the top of the page click on the group icon. This will open an edit menu, that will allow you to change your icon.
After all of that in my case it was still necessary to update the logo through the Sharepoint Site's "Change the look", and then delete the __siteicon__.png or .jpg, in the Site Assets folder.
Hope this can help someone!
Still not working for us either - we've changed it every which way, through Teams, Outlook and Sharepoint but the logo still doesn't show up in Teams. We've deleted the site asset through sharepoint (which gets recreated every time you upload a thumbnail) and tried different image sizes (this is the simplest of icons). If anyone works it out, please let us know!

@Alireza Rahimifarid how can this be right when you cant change site logo in site information....

Just in case anyone is still having this problem, or stumbles across this, I was having problems updating the Thumbnail on one of our sites - every other site updated fine, but one site was being stubborn - the logo was updating fine, but not the thumbnail.

I noticed in 'Site Assets' on the sites that worked included both '__siteIcon__.png' and '__siteIcon__.jpg'.
As I was just using a .png file for icon and thumbnail I assume it was converting the file to jpg itself on the sites that worked, but on the site that wasn't working there was only '__siteIcon__.png', so I saved the file I was using as a .jpg and tried again, and it successfully updated the thumbnail and  had '__siteIcon__.jpg' in the site assets folder.

So, if you're having problems, try using a different file type.