Sharepoint List Web Part says the Year 1899 from internal Created Date - worked, but now its 1899

New Contributor

Hi, I've tried to find the answer for this problem and while I find the same symptom, I can't find anyone with the same problem/solution.


We have a sharepoint site that collects hours from a number of sources for a live time logging system, up until yesterday things were find then 5 date submissions all show in a web part as having the date 31/12/1899, which as i read is the expected behaviour when using a blank date field. However this field looks at the system 'Created' field, therefore cannot be blank and when looked at outside the web part, in the list view the dates are fine. Strangely the web part still see's the entries as the most recent as this view is sorted by the created date.


Any insights you may have would be greatly appreciated, I'm pretty sure my team aren't working in the Victorian age. Thank you.




6 Replies

@Siewake as a test if you change that site "locale" settings does it show properly ?

@Bruno AleixoYes it does, setting to a locale with a US style date format displays the inteded result (2020!) for that locale. Thank you for taking the time to answer here. It doesn't exactly solve my problem but it gives me hope that there is a simple solution here. I'm trying to get the UK version. I've tried a few so far, hopefully I'll find one that I can just put up with. Thanks for the pointer.

@Siewake thanks. we are working on a fix for this issue and should be fixed soon. While that does not happen the workaround is the best option.

@Bruno AleixoAre there any further details of the issue? I may be happy to live with it until a fix can be made, it would upset my main users more to change the date format on the main lists in this site to a non-regional format and cause confusion between systems.

@Siewake Its a visual issue on the group by. If you verify the items themselves they have the correct dates. Another workaround would be to group by a different column. 

@Bruno Aleixo  Thank you so much, knowing that I have made a new column called Logged which is a calculated column of the =[Created] and it works like that - so problem solved for now. Thanks for your help, I could have gone on forever! - Simon