SharePoint list not saving input - Person type field

%3CLINGO-SUB%20id%3D%22lingo-sub-917328%22%20slang%3D%22en-US%22%3ESharePoint%20list%20not%20saving%20input%20-%20Person%20type%20field%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-917328%22%20slang%3D%22en-US%22%3E%3CP%3EHi%20there%2C%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20a%20problem%20with%20SharePoint.%20I%20have%20set%20up%20a%20field%20of%20type%20'Person'%2C%20but%20when%20trying%20to%20add%20content%20nothing%20is%20inputted%20in%20the%20field.%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20628px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F138128iCC445E3F2E4C3CAF%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22SharepointIssue.gif%22%20title%3D%22SharepointIssue.gif%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAnyone%20having%20the%20same%20problem%3F%20is%20there%20a%20bug%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-917328%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-917342%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20list%20not%20saving%20input%20-%20Person%20type%20field%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-917342%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20another%20'Person'%20type%20field%20with%20single%20selection%20that%20works%2C%20but%20clicking%20on%20the%20cross%20to%20delete%20doesn't%20work...%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20image-alt%3D%22SharepointIssue2.gif%22%20style%3D%22width%3A%20628px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F138131i66C22C92629748D6%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20title%3D%22SharepointIssue2.gif%22%20alt%3D%22SharepointIssue2.gif%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20can%20only%20delete%20using%20the%20backspace%20and%20enter.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1153937%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20list%20not%20saving%20input%20-%20Person%20type%20field%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1153937%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F385038%22%20target%3D%22_blank%22%3E%40David_Gd%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20the%20exact%20same%20issue.%20I%20even%20opened%20a%20ticket%20with%20Microsoft...no%20answer%20yet.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1153948%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20list%20not%20saving%20input%20-%20Person%20type%20field%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1153948%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F385038%22%20target%3D%22_blank%22%3E%40David_Gd%3C%2FA%3E%26nbsp%3BJust%20checking%20what%20are%20your%20Additional%20list%20settings%3F%20If%20you%20enforce%20unique%20values%20and%20that%20value%20exists%20already%2C%20it%20won't%20work.%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-left%22%20image-alt%3D%22ListSettings.JPG%22%20style%3D%22width%3A%20290px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F169243i7E692349FD91E279%2Fimage-size%2Fmedium%3Fv%3D1.0%26amp%3Bpx%3D400%22%20title%3D%22ListSettings.JPG%22%20alt%3D%22ListSettings.JPG%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1153966%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20list%20not%20saving%20input%20-%20Person%20type%20field%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1153966%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F4163%22%20target%3D%22_blank%22%3E%40Andrew%20Warland%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20me%20it's%20a%20brand%20new%20list%20with%20a%20person%20field%20-%20with%20just%20default%20settings%20on%20the%20column.%20So%20no%20unique%20is%20not%20selected.%20This%20also%20occurs%20when%20you%20go%20and%20try%20to%20remove%20a%20name.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBasically%2C%20if%20you%20keep%20clicking%20around%20and%20playing%20with%20it%20enough...you%20can%20force%20it%20into%20submission...literally%20and%20figuratively.%20However%2C%20it's%20embarrassing%20to%20go%20to%20your%20end%20users%20and%20say...just%20keep%20clicking%20and%20eventually%20it%20will%20work.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20have%20an%20open%20ticket%20and%20each%20week%20I%20get%20an%20email%20from%20MS%20saying%20that%20they%20have%20sent%20the%20issue%20to%20the%20%22escalation%20team%22%20and%20are%20awaiting%20an%20update.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20am%20developing%20a%20solution%20that%20implements%20a%20person%20field%20and%20I've%20basically%20been%20in%20this%20weird%20holding%20pattern%20until%20this%20gets%20resolved.%20While%20I'm%20sorry%20others%20are%20having%20the%20issue...it%20does%20feel%20good%20to%20know%20that%20I'm%20not%20just%20imagining%20this%20bug.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1154879%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20list%20not%20saving%20input%20-%20Person%20type%20field%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1154879%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F28814%22%20target%3D%22_blank%22%3E%40Michael%20Malloy%3C%2FA%3E%2C%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F4163%22%20target%3D%22_blank%22%3E%40Andrew%20Warland%3C%2FA%3E%2C%3C%2FP%3E%3CP%3EThanks%20for%20your%20messages.%20I've%20never%20found%20a%20solution%20for%20that.%3C%2FP%3E%3CP%3EMy%20work%20brought%20me%20to%20other%20duties.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Contributor

Hi there,

 

I have a problem with SharePoint. I have set up a field of type 'Person', but when trying to add content nothing is inputted in the field.

SharepointIssue.gif

 

Anyone having the same problem? is there a bug?

5 Replies

I have another 'Person' type field with single selection that works, but clicking on the cross to delete doesn't work...

SharepointIssue2.gif

 

I can only delete using the backspace and enter.

@David_Gd 

 

I have the exact same issue. I even opened a ticket with Microsoft...no answer yet.

@David_Gd Just checking what are your Additional list settings? If you enforce unique values and that value exists already, it won't work. 

ListSettings.JPG

@Andrew Warland 

 

For me it's a brand new list with a person field - with just default settings on the column. So no unique is not selected. This also occurs when you go and try to remove a name.

 

Basically, if you keep clicking around and playing with it enough...you can force it into submission...literally and figuratively. However, it's embarrassing to go to your end users and say...just keep clicking and eventually it will work.

 

I have an open ticket and each week I get an email from MS saying that they have sent the issue to the "escalation team" and are awaiting an update.

 

I am developing a solution that implements a person field and I've basically been in this weird holding pattern until this gets resolved. While I'm sorry others are having the issue...it does feel good to know that I'm not just imagining this bug.

@Michael Malloy@Andrew Warland,

Thanks for your messages. I've never found a solution for that.

My work brought me to other duties.