SharePoint list is not showing images from lookup column

%3CLINGO-SUB%20id%3D%22lingo-sub-1119378%22%20slang%3D%22en-US%22%3ESharePoint%20list%20is%20not%20showing%20images%20from%20lookup%20column%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1119378%22%20slang%3D%22en-US%22%3E%3CP%3EI%20have%20a%20list%20which%20when%20people%20add%20a%20new%20item%20it%20pulls%20in%20an%20image%20from%20a%20library%20using%20a%20lookup%20column%20and%20json%20format.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F166237i14C13A9034DC3682%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Screenshot%202019-06-13%20at%2018.59.53.png%22%20title%3D%22Screenshot%202019-06-13%20at%2018.59.53.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EFor%20some%20reason%20it's%20suddenly%20stopped%20working%20even%20though%20i've%20not%20changed%20anything!%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F166236iDA51FCA38CACC6AE%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22Screenshot%202020-01-21%20at%2008.58.56.png%22%20title%3D%22Screenshot%202020-01-21%20at%2008.58.56.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20JSON%20formatting%20is%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%7B%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%22%24schema%22%3A%20%22%3CA%20href%3D%22https%3A%2F%2Fdeveloper.microsoft.com%2Fjson-schemas%2Fsp%2Fcolumn-formatting.schema.json%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdeveloper.microsoft.com%2Fjson-schemas%2Fsp%2Fcolumn-formatting.schema.json%3C%2FA%3E%22%2C%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%22elmType%22%3A%20%22img%22%2C%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%22attributes%22%3A%20%7B%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%22src%22%3A%20%22%3D%40currentWeb%20%2B%20'%2FPraise%20Badges%2F'%20%2B%20%40currentField%22%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%7D%2C%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%22style%22%3A%20%7B%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%22width%22%3A%20%22100px%22%2C%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%22height%22%3A%20%22100px%22%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%7D%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3CBR%20%2F%3E%3CFONT%20size%3D%223%22%3E%3CSTRONG%3E%3CFONT%20face%3D%22courier%20new%2Ccourier%22%3E%7D%3C%2FFONT%3E%3C%2FSTRONG%3E%3C%2FFONT%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20don't%20know%20if%20it's%20the%20JSON%20or%20something%20Microsoft%20has%20changed%20in%20the%20background%2C%20but%20if%20anyone%20has%20any%20ideas%20it%20would%20be%20much%20appreciated!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1119378%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Contributor

I have a list which when people add a new item it pulls in an image from a library using a lookup column and json format.

 

Screenshot 2019-06-13 at 18.59.53.png

 

For some reason it's suddenly stopped working even though i've not changed anything!

 

Screenshot 2020-01-21 at 08.58.56.png

 

The JSON formatting is

 

{
"$schema": "https://developer.microsoft.com/json-schemas/sp/column-formatting.schema.json",
"elmType": "img",
"attributes": {
"src": "=@currentWeb + '/Praise Badges/' + @currentField"
},
"style": {
"width": "100px",
"height": "100px"
}
}

 

I don't know if it's the JSON or something Microsoft has changed in the background, but if anyone has any ideas it would be much appreciated!

0 Replies