Sharepoint list edits take 5 minutes

%3CLINGO-SUB%20id%3D%22lingo-sub-2083876%22%20slang%3D%22en-US%22%3ESharepoint%20list%20edits%20take%205%20minutes%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2083876%22%20slang%3D%22en-US%22%3E%3CP%3EI%20almost%20put%20this%20question%20in%20the%20developer%20forum%2C%20but%20it's%20not%20really%20a%20workflow%20question.%3C%2FP%3E%3CP%3EWe%20have%20a%20task%20list%20that%20I%20was%20asked%20to%20create%20a%20simple%20SPD%20workflow%20on.%26nbsp%3B%20On%20edits%2C%20the%20WF%20would%20check%20to%20see%20if%20three%20date%20fields%20were%20filled%20in%2C%20and%20if%20so%20it%20would%20send%20an%20email.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPretty%20simple%20workflow.%26nbsp%3B%20I%20finish%20it%2C%20and%20then%20create%20a%20new%20task%20and%20save%20it.%26nbsp%3B%20I%20then%20reopen%20the%20task%2C%20edit%20it%2C%20make%20a%20change%2C%20and%20then%20save%20it.%26nbsp%3B%20When%20I%20do%20that%20the%20chrome%20circle%20just%20spins%20and%20spins%20and%20spins%2C%20for%20around%205%20minutes.%26nbsp%3B%20I%20thought%20what%20the%20heck%20was%20that%3F%26nbsp%3B%20%26nbsp%3BSo%20I%20make%20another%20change%2C%20and%20this%20time%20fill%20in%20all%203%20dates.%26nbsp%3B%20The%20same%20thing%20happens%20where%20it%20spins%20and%20spins%2C%20and%20the%20page%20refreshes%20at%205%20minutes%2C%20and%20just%20at%20that%20point%20the%20email%20arrives%20in%20my%20inbox%2C%20(I%20was%20having%20the%20emails%20go%20to%20me%20during%20testing%20instead%20of%20the%20business%20user).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESo%20I%20keep%20playing%20with%20this%20and%20notice%20that%20as%20soon%20as%20I%20hit%20save%2C%20the%20data%20show%20up%20in%20the%20list%2C%20(I%20had%20the%20list%20open%20in%20another%20tab)%2C%20but%20the%20tab%20with%20the%20open%20item%20will%20not%20refresh%20until%20the%20timer%20job%20sends%20the%20email.%26nbsp%3B%20I%20had%20never%20seen%20anything%20like%20that%20before.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ESince%20that%20wasn't%20going%20to%20work%20at%20all%20I%20removed%20the%20workflow%2C%20recreated%20it%2C%20and%20found%20the%20same%20thing%20happened%20with%20a%20new%20workflow.%26nbsp%3B%20Even%20if%20I%20didn't%20fill%20in%20the%20three%20fields%20on%20the%20edit%20task%20form%20it%20would%20still%20take%205%20minutes%2C%20(so%20it%20wasn't%20getting%20stuck%20in%20a%20loop%20inside%20the%20workflow).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI%20then%20removed%20the%20WF%20completely%2C%20and%20it%20still%20kept%20happening.%26nbsp%3B%20%3A(%3C%2Fimg%3E%26nbsp%3B%20%26nbsp%3BI%20then%20made%20a%20template%20of%20the%20list%2C%20deleted%20it%2C%20and%20recreated%20it%20from%20the%20list%2C%20(it's%20a%20large%20custom%20task%20list).%26nbsp%3B%20Sure%20enough%20the%20exact%20same%20problem%20is%20happening%2C%20even%20though%20I%20have%20a%20new%20name%20for%20the%20list%2C%20and%20no%20WF%20ever%20created%20for%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20never%20seen%20anything%20like%20this%20before.%26nbsp%3B%20From%20everything%20that%20I%20can%20see%20it%20looks%20like%20the%20screen%20refresh%20for%20that%20list%20is%20now%20tied%20to%20the%205%20minute%20timer%20job%20completing.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20thoughts%20on%20how%20I%20can%20fix%20that%3F%26nbsp%3B%20(Other%20than%20recreating%20this%20entire%20list%20from%20scratch)%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks.%3C%2FP%3E%3CP%3ETed%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2083876%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

I almost put this question in the developer forum, but it's not really a workflow question.

We have a task list that I was asked to create a simple SPD workflow on.  On edits, the WF would check to see if three date fields were filled in, and if so it would send an email.

 

Pretty simple workflow.  I finish it, and then create a new task and save it.  I then reopen the task, edit it, make a change, and then save it.  When I do that the chrome circle just spins and spins and spins, for around 5 minutes.  I thought what the heck was that?   So I make another change, and this time fill in all 3 dates.  The same thing happens where it spins and spins, and the page refreshes at 5 minutes, and just at that point the email arrives in my inbox, (I was having the emails go to me during testing instead of the business user).

 

So I keep playing with this and notice that as soon as I hit save, the data show up in the list, (I had the list open in another tab), but the tab with the open item will not refresh until the timer job sends the email.  I had never seen anything like that before.

 

Since that wasn't going to work at all I removed the workflow, recreated it, and found the same thing happened with a new workflow.  Even if I didn't fill in the three fields on the edit task form it would still take 5 minutes, (so it wasn't getting stuck in a loop inside the workflow).

 

I then removed the WF completely, and it still kept happening.  :(   I then made a template of the list, deleted it, and recreated it from the list, (it's a large custom task list).  Sure enough the exact same problem is happening, even though I have a new name for the list, and no WF ever created for it.

 

I've never seen anything like this before.  From everything that I can see it looks like the screen refresh for that list is now tied to the 5 minute timer job completing.

 

Any thoughts on how I can fix that?  (Other than recreating this entire list from scratch)

 

Thanks.

Ted

 

0 Replies