Sharepoint list, data not showing in form but in list.

Occasional Contributor



A strange thing happend today. I think it might have occured when I added a new item from "row-view". But not sure. 


Anyway, as can be seen in the picture below, the data from the list is missing from the form, but viewable in the list. 


What might have happend and what can I do to fix it?


I'm grateful for any tips!


2021-10-11 15_54_26-Grot lager - Albin Lars.png

11 Replies

@bob_sacamano did you have some response about this?


I have the same issue happened to me this week, never had this problem before. 

Still having this issue. I can edit an view all data in the "edit in row-net view" but not in the standard form.
No responses, would very much appreciate some.
Occured to me again this week. Seams to be occurring when i work heavily on a list, like som overload issue. But now it persist, before it went back to normal over night.

@bob_sacamano Had it happened from time to time. When i erased the browsing history in Edge, the items were visible in the SharePoint Form. So i guess i'll be doing this until a solution is found.


Aha, that worked! Thank you so much! Now I don't have to contact my expensive IT-vendor just for some small thing like this.

I wish you a very good day Sir!



This matter continues to haunt me. For my users I insert the sharepoint list into teams, and now the same thing happens there. But how can I "clear history or cookies" from MS teams?

@Martin_Bilodeau I'm having the same problems in MS teams. I've added the list to a Team. But I how can I accomplish "clearing browser history" in Teams? 

I did this( cleared the cache) and it worked for a couple of minutes before it returned to the same issue. I've tested several browsers, Chrome, Edge, Firefox but all of them have the issue. I have not changed any settings for this list. I created a new view and suddenly it started to work but quickly returned to the issue. This is really frustrating.

@Nitramarbok That is also my experience. My belief is that I've accidently done something that messed up the links somehow. Because if I search the object and click on it in the "search proposals dropdown list" it Works, but if I press enter and click on one of the search results, the same problems appear.