SharePoint List customize with PowerApps > user being impersonated issue

%3CLINGO-SUB%20id%3D%22lingo-sub-1541144%22%20slang%3D%22en-US%22%3ESharePoint%20List%20customize%20with%20PowerApps%20%26gt%3B%20user%20being%20impersonated%20issue%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1541144%22%20slang%3D%22en-US%22%3E%3CP%3EI%20am%20not%20sure%20where%20to%20start%20with%20this%20issue%2C%20but%20I%20will%20try%20and%20explain%20%26gt%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3COL%3E%3CLI%3EWe%20have%20created%20a%20SP%20List%20and%20used%20the%20Customize%20with%20PowerApps.%3C%2FLI%3E%3CLI%3EIf%20'I'%20add%20a%20new%20item%20via%20the%20PowerApp%20New%20Form%20the%20SP%20list%20item%20is%20entered%20with%20a%20Created%20By%20that%20is%20not%20myself%20(it%20is%20one%20of%20our%20admin%20accounts).%26nbsp%3B%20This%20does%20not%20appear%20to%20effect%20other%20users%20just%20me%20logged%20in%20as%20me.%3C%2FLI%3E%3CLI%3EIf%20'I'%20use%20the%20Quick%20Edit%20in%20the%20SP%20List%2C%20the%20entry%20goes%20in%20as%20Created%20by%20ME%3C%2FLI%3E%3CLI%3ESo%20we%20have%20obviously%20determined%20that%20it%20is%20something%20to%20do%20with%20the%20PowerApp%2C%20but%20we%20are%20lost%20as%20to%20what%20in%20the%20PowerApp%20is%20causing%20this%20issue.%3C%2FLI%3E%3C%2FOL%3E%3CUL%3E%3CLI%3EThe%20PowerApp%20does%20have%20some%20functionality%20that%20hides%2Fshows%20some%26nbsp%3B%20buttons%20on%20the%20various%20forms%20depending%20on%20a%20Status%20field.%3C%2FLI%3E%3C%2FUL%3E%3CP%3ECan%20anyone%20shed%20some%20light%20as%20to%20how%20we%20debug%20this%20issue%20or%20even%20better%20how%20to%20fix%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3Ep.s.%20posted%20the%20same%20message%20in%20the%20PowerApps%20Community%20but%20only%20one%20response.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1541144%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Super Contributor

I am not sure where to start with this issue, but I will try and explain >

 

  1. We have created a SP List and used the Customize with PowerApps.
  2. If 'I' add a new item via the PowerApp New Form the SP list item is entered with a Created By that is not myself (it is one of our admin accounts).  This does not appear to effect other users just me logged in as me.
  3. If 'I' use the Quick Edit in the SP List, the entry goes in as Created by ME
  4. So we have obviously determined that it is something to do with the PowerApp, but we are lost as to what in the PowerApp is causing this issue.
  • The PowerApp does have some functionality that hides/shows some  buttons on the various forms depending on a Status field.

Can anyone shed some light as to how we debug this issue or even better how to fix it.

 

p.s. posted the same message in the PowerApps Community but only one response.

0 Replies