SharePoint Link to Document Won't Download

%3CLINGO-SUB%20id%3D%22lingo-sub-564635%22%20slang%3D%22en-US%22%3ESharePoint%20Link%20to%20Document%20Won't%20Download%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-564635%22%20slang%3D%22en-US%22%3E%3CP%3ETrying%20to%20get%20a%20document%20link%20to%20open%20only%20as%20a%20Download%20on%20my%20Homepage%20in%20the%20Hero%20webpart.%20I%20put%20the%20following%20in%20the%20Link%3A%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fbostonscientific.sharepoint.com%2Fsites%2FEndoLL2%2FShared%2520Documents%2FMain%2520Documents%2FLL%2520Install%2520WI%25205.13.docx%3Fdownload%3D1%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmycompany.sharepoint.com%2Fsites%2FEndoLL2%2FShared%2520Documents%2FMain%2520Documents%2FLL%2520Install%2520WI%25205.13.docx%3Fdownload%3D1%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20I%20save%2C%20this%20is%20the%20link%20I%20get%3A%3C%2FP%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Fmycompany.sharepoint.com%2Fsites%2FEndoLL2%2FShared%2520Documents%2FMain%2520Documents%2FLL%2520Install%2520WI%25205.13.docx%3Fdownload%3D1%26amp%3Bweb%3D1%22%20target%3D%22_blank%22%20rel%3D%22noopener%20nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fmycompany.sharepoint.com%2Fsites%2FEndoLL2%2FShared%2520Documents%2FMain%2520Documents%2FLL%2520Install%2520WI%25205.13.docx%3Fdownload%3D1%26amp%3Bweb%3D1%3C%2FA%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20hero%20automatically%20added%22%26nbsp%3B%26amp%3Bweb%3D1%22%20to%20the%20end%20of%20the%20link%20address.%20Link%20otherwise%20works%20if%20I%20try%20and%20open%20it%20directly.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20how%20to%20stop%20the%20automatic%20adding%20to%20open%20it%20in%20the%20web%20based%20app%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-564635%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EFiles%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-565036%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Link%20to%20Document%20Won't%20Download%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-565036%22%20slang%3D%22en-US%22%3EUnfortunately%20there%20is%20no%20way%20you%20can%20instruct%20(at%20least%20I'm%20aware%20of)%20the%20hero%20WebPart%20to%20keep%20the%20links%20in%20the%20way%20you%20want%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-584354%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Link%20to%20Document%20Won't%20Download%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-584354%22%20slang%3D%22en-US%22%3ECreate%20a%20sharing%20link%20from%20the%20document.%20Then%20add%20%3Fdownload%3D1%20to%20the%20end%20and%20you%20should%20be%20good.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-774818%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%20Link%20to%20Document%20Won't%20Download%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-774818%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F869%22%20target%3D%22_blank%22%3E%40Chris%20Webb%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThis%20doesn't%20seem%20to%20work%20any%20more.%20The%20file%20still%20opens%20in%20the%20relevant%20browser-based%20app.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

Trying to get a document link to open only as a Download on my Homepage in the Hero webpart. I put the following in the Link:

 

https://mycompany.sharepoint.com/sites/EndoLL2/Shared%20Documents/Main%20Documents/LL%20Install%20WI...

 

When I save, this is the link I get:

https://mycompany.sharepoint.com/sites/EndoLL2/Shared%20Documents/Main%20Documents/LL%20Install%20WI...

 

 

The hero automatically added" &web=1" to the end of the link address. Link otherwise works if I try and open it directly.

 

Does anyone know how to stop the automatic adding to open it in the web based app?

3 Replies
Highlighted
Unfortunately there is no way you can instruct (at least I'm aware of) the hero WebPart to keep the links in the way you want
Highlighted
Create a sharing link from the document. Then add ?download=1 to the end and you should be good.
Highlighted

@Chris Webb 

 

This doesn't seem to work any more. The file still opens in the relevant browser-based app.