SharePoint Document Library Properties not Loading

%3CLINGO-SUB%20id%3D%22lingo-sub-1628873%22%20slang%3D%22en-US%22%3ESharePoint%20Document%20Library%20Properties%20not%20Loading%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1628873%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20are%20having%20a%20bizarre%20issue%20while%20trying%20to%20edit%20document%20properties%20in%20a%20document%20library.%26nbsp%3B%20This%20isuue%20seems%20to%20occur%20in%201%20library%20and%20not%20any%20others.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E1.%20Properties%20not%20loading%20when%20selecting%20the%20info%20button%20from%20a%20library%20view%20embedded%20on%20a%20page.%26nbsp%3B%20They%20get%20stuck%20on%20loading%20and%20never%20load.%20(Image%201%3A%20Started%20September%201)%3C%2FP%3E%3CP%3E2.%20When%20clicking%20details%20on%20the%20document%20from%20the%20actual%20document%20library%2C%20a%20brown%20box%20appears%20instead%20of%20the%20properties%20panel%20(Image%202%3A%20this%20started%20September%202%20--%20we%20were%20using%20it%20as%20a%20workaround%20to%20issue%201).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAny%20idea%20what%20could%20be%20causing%20these%20issues%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1628873%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1628974%22%20slang%3D%22de-DE%22%3ESubject%3A%20SharePoint%20Document%20Library%20Properties%20not%20Loading%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1628974%22%20slang%3D%22de-DE%22%3E%3CP%3EHello%20%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F779949%22%20target%3D%22_blank%22%3E%40bhopkinsfl%3C%2FA%3E%20%2C%3C%2FP%3E%3CP%3Ethanks%20for%20your%20screenshots.%20The%20%22library%22%20looks%20like%20a%20page%2C%20containing%203%20views%20an%20the%20same%20doc%20library.%20Maybe%20the%20link%20to%20the%20Page%20of%20the%203%20Library%20views%20was%20set%20in%20the%20left%20navigation.%20I%20guess%2C%20the%20author%20aimed%20to%20conceal%20the%20real%20doc%20library%20access.%20For%20instance%20go%20to%20your%20Gear%20at%20the%20top%20right%2C%20then%20choose%20%22Site%20contents%22%2C%20so%20your%20original%20lists%20and%20libraries%20are%20here%20again.%20When%20viewing%20the%20doc%20library%2C%20just%20try%20again%20the%20gear%20icon%2C%20then%20choose%20library%20settings.%20Here%20you%20can%20set%20up%20your%20library%20options%20with%20the%20views%2C%20columns%2C%20and%20other%20options%20within.%20Hope%20that%20helps%2C%20Eva.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
New Contributor

We are having a bizarre issue while trying to edit document properties in a document library.  This isuue seems to occur in 1 library and not any others.

 

1. Properties not loading when selecting the info button from a library view embedded on a page.  They get stuck on loading and never load. (Image 1: Started September 1)

2. When clicking details on the document from the actual document library, a brown box appears instead of the properties panel (Image 2: this started September 2 -- we were using it as a workaround to issue 1).

 

Any idea what could be causing these issues?

 

 

4 Replies
Highlighted

Hello @bhopkinsfl ,

thanks for your screenshots. The "library" looks like a Page, containing 3 Views an the same doc library.

 

Maybe the link to the Page of the 3 Library views  was set in the left navigation. I guess, the author aimed to conceal the real doc library access.

 

You can simply click on the button "Page Details" and i guess furthermore its only for change the Page settings.

 

1) Library Settings are allways on the Gear. All Pages are in the site contents - "Site Pages Library".

 

2) for your doc library: Go to your Gear at the top right, then choose "Site contents", so your original lists and libraries are here again.

 

3) When you see the doc library at the view "All Documents", just try again the gear icon, then choose library settings.

 

4) Here you can set up your library options with the views, columns, and other options within. I think thats what you meant with "Library properties".

 

4a) If theres no way to find the library settings / options because you can t see them, you dont have permission to change or see it. If you are a site owner, you can do it.

 

5) Hope that helps, Eva. 

Highlighted

@Eva Vogel 

 

Hi Eva,

 

Yes, I have gone into the actual library. 

 

I am attempting to edit the properties of individual documents.  In there, when I click "details" on the document it opens the properties panel and shows the brown box instead of the properties (image 2). 

 

I just tested and this only happens in modern view.  Switching back to classic view allows me to change the properties using the old experience. 

Highlighted

Hi @bhopkinsfl ,

OK. User defined scripts, migrated from classic sites, are allways an issue in modern Sites /Lists/Libraries. 

I think, the author of that site / library experimented with the classic "script editor webpart" and the result is that blocking square brown thing on your docs property pane.

 

Microsoft has not yet provided - so far -for a "modern script editor webpart". some companies are doing those individual scriptings with SPFx (the SharePoint Framework/x UI, that is available for developpers mostly with the right developper permission level in a tenant.

 

The UI SPFx (GitHub.com Portal) can be used to eliminate that brown block, because i guess it is a css object, coded for restricting viewing documents?

 

So there will be some errors while migrating classic Sites and I strongly recommend deactivating all of  the user defined scripts (XML, CSS, HTML, whatever). They don´t fit into the new javascript coding structure seemlessly... They error out every time someone uses a scripted library like yours. Mostly the script developers don´t have no clue what permissions level exist in a site and therefore they work with conditional forms like that brown block object which are visible when a person has got no permisson to view certain informations about the doc, roughly speaking. 

 

Hope that helps, see screenshots attached and deactivate that modern script features in your Site. User Defined Scripts can only be deactivated if you are a SP Admin!

 

MS 365 Admin Center ==>SharePoint Admin Center ==> Settings ==> Hyperlink "Classic Options" (settings? dont know..) In this very old page you have to search on the topic "User defined Scripts", like I did in my screenshot. So I think your doc library will show the properties then and the scripts won´t be active furthermore. BUT! This concerns THE WHOLE SharePoint Environment, be carefull. All old scripts will be disfunctional then. No guarantee on my behalf! Please ask your SP Admin what to do with the classic scriptings.

 

If you succeeded, pls. give a thumbs up.

 

 

 

 

 

Highlighted

@Eva Vogel 

 

Hi Eva,

 

Thanks for you response.   We will look into this.

 

Bob