SharePoint Document Library Default Tags

%3CLINGO-SUB%20id%3D%22lingo-sub-1690133%22%20slang%3D%22en-US%22%3ESharePoint%20Document%20Library%20Default%20Tags%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1690133%22%20slang%3D%22en-US%22%3E%3CP%3EHello%2C%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWe've%20ran%20into%20a%20small%20problem%20with%20the%20default%20column%20values%20feature%20on%20a%20SharePoint%20Online%20document%20library.%3C%2FP%3E%3CP%3EWe've%20set%20up%20the%20enterprise%20keyword%20columns%20default%20values%20on%20a%20library%2C%20and%20it%20works%20fine%20most%20of%20time%20and%20adds%20the%20tags%20to%20the%20uploaded%20file%2C%20but%20if%20a%20user%20uses%20the%20new%20button%20and%20adds%20a%20new%20docx%20file%20from%20the%20default%20templates%2C%20it%20doesn't%20work.%26nbsp%3B%20The%20main%20reason%20is%20that%20the%20template%20docx%20has%20no%20keywords%20set%20in%20it's%20metadata%2C%20but%20we%20observed%20different%20behavior%20when%20uploading%20files%3A%20if%20the%20uploaded%20docx%20has%20no%20keywords%20set%2C%20it%20gets%20overwritten%20correctly.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3BAs%20a%20workaround%20we've%20tried%20to%20modify%20the%20default%20templates%20keywords%20to%20match%20the%20settings%20on%20the%20doc%20library%2C%20but%20we've%20found%20no%20method%20to%20do%20this.%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThank%20in%20advance.%3C%2FP%3E%3CP%3ELevente%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1690133%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EDefault%20Column%20Values%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EDocument%20Library%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EEnterprise%20Keywords%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3Eissue%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EMetadata%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EOnline%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Regular Visitor

Hello, 

 

We've ran into a small problem with the default column values feature on a SharePoint Online document library.

We've set up the enterprise keyword columns default values on a library, and it works fine most of time and adds the tags to the uploaded file, but if a user uses the new button and adds a new docx file from the default templates, it doesn't work.  The main reason is that the template docx has no keywords set in it's metadata, but we observed different behavior when uploading files: if the uploaded docx has no keywords set, it gets overwritten correctly. 

 

 As a workaround we've tried to modify the default templates keywords to match the settings on the doc library, but we've found no method to do this. 

 

Thanks in advance.

Levente

0 Replies