SharePoint column data not showing up. What is happening?

Copper Contributor

My Name column on SharePoint is not populating with the appropriate data fields. I can see the data when I click on an individual entry but I can't see the data in the column on SharePoint. I can also see it on gallery view but not on list view. 

Anyone know what's going on here? 


20 Replies


  1. What is the data type of Name column?
  2. Is there any JSON formatting applied for this column in List view?

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

Thank you for replying.
1. It is a single line of text.
2. The JSON formatting is
"$schema": ""

@PN3456789 This is the default reference to JSON formatting schema. This shouldn't be a problem in your case.

This is a strange issue. Never saw such type of issue in our SharePoint tenant. I will suggest you to open a support ticket with Microsoft, check: Get Online support 

Please click Mark as Best Response & Like if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

Hi @PN3456789,


Came across this issue myself, the following fixed it for me.


1)  Click on one of the heading and choose - "Column settings" then click on "Show/hide columns"

2)  Scroll through and look to see if you have two "Name" options.

3)  on the RHS window - Untick the currently ticked one "Name"

4)  Tick the "Name" which was unticked

5)  click "Apply"


Hopefully you already sorted this, and hopefully this helps others.


Had the same issue, What solved it for me was to go to the Column that is not displaying values > Column Settings > Format this Column > erase the JSON code then save... worked like a charm. For me at the very least
@Daryl1396 This just saved me!!! Thank you... there was some odd enduser data in the JSON code, maybe the enduser had the list open at the time I made format change... it was driving me nuts all weekend and our IT Dept was stumped too... I share your fix with them... it was a life saver thank you!!!

@PN3456789 First, let's take a closer look at the column configuration. You mentioned that the column is a "Name" column with a single line of text data type. That's a common and standard column type, so the issue is likely not related to the column configuration itself.


However, the fact that you can see the data when clicking on individual entries, but not in the list view, suggests that there may be some formatting or display issues at play. The JSON formatting you described is a common way to customize the appearance of columns in SharePoint, but it's possible that there's something in the formatting that's causing the data to not display correctly in the list view. My recommendation would be to start by removing the JSON formatting entirely and see if that resolves the issue.


As suggested by one of the previous replies, you can do this by going to the column settings, clicking on "Format this column," and then simply deleting the JSON code and saving the changes. If removing the formatting doesn't work, you may need to dig a bit deeper. It's possible that there's an issue with the way the data is being retrieved or cached in the list view. In some cases, a simple refresh of the page or a full re-indexing of the list can help resolve these kinds of display issues.

I was having this issue also and came across the answer that @knot_that_smart gave. However, I did not have two fields with the same name. What ended up working for me was to hide the column and then un-hiding the column. After that, everything came back.

1)  Click on one of the heading and choose - "Column settings" then click on "Show/hide columns"

2)  Untick the current issue field.

3)  Click "Apply"

4)  Click on one of the heading and choose - "Column settings" then click on "Show/hide columns"

5)  Tick the current issue field.

6)  Click "Apply"


After that, everything came back. It did appear all the way over to the right, but I just dragged it back to the correct position.


@IT_Manager-GZA I tried all the solutions proposed above, but the text in the title column is still not showing. I can only see what's in it after clicking in the individual entry. This started today. Yesterday everything was ok.

@Andre_Oliveira Interesting. I am not sure what to tell you as that solution above worked for me. Have you tried creating a new View and/or used a new column with calculated formula to reference that problem column? Those might be some alternative workarounds to get the data to re-appear. Good luck!


It had also the same issue, Title colum that I had already changed the name to 'Nom', it shows Title column and no data visible. Only visible when edit item.
Go to List settings, views and click on All items. Check if there are two columns (Title, Name Changed), then disable one. 

Im in the same situation with the Title column ... Any solutions now?

Este tipo de errores o pasa por temas de JSON al darle formato a la columna o bien porque quisiste añadir una columna de busqueda, en el caso que situes una columna de busqueda y la columna es Title, sucede esto.

Deberias ir a la configuración de la lista, tienes que editar la vista actual donde te van aparecer todas las columnas. En mi caso, se ve perfectamente como la columna Title esta seleccionada y la columna que realmente es Title no lo esta. @DanyPereyra 

Sabes que no he agregado columnas de búsqueda ni editado nada en el JSON, el rollo es que todas mis listas de diferentes sitios se actualizaron solas y en todas se renombró sola la columna de nuevo como "Title" (porque en la mayoría les había cambiado el nombre), pero ahora no muestra nada de info, igual cuando abro el item a detalle si tiene los datos, pero no me deja manipular esa info

Sabes si hay alguna otra solución?
Puedes editar la vista de todos los elementos y comprobar que este la columna con el nombre que pusiste?
Thank you for all the help!
I am staying with excel spreadsheets. I was testing Lists as an alternative also because of the mobile phone app. It seems it is not stable and reliable enough. I will consider it again when it's more dependable.
Here are two compelling arguments for transitioning from Excel to Microsoft Lists:

Enhanced Collaboration: Microsoft Lists is specifically designed for team collaboration, allowing multiple users to work simultaneously on the same list without the risk of conflicts or data loss that can occur in Excel. Lists also integrate seamlessly with other Microsoft 365 applications, like Teams and SharePoint, making it easier to manage workflows and share data across your organization in real-time.
Customization and Automation: Microsoft Lists offers greater flexibility for customization and automation compared to Excel. You can use smart rules and alerts to automate tasks and ensure critical updates are communicated instantly. This can help streamline processes and increase efficiency, particularly for task management and tracking progress, which are less intuitive in Excel.
Switching to Microsoft Lists could significantly enhance your team’s productivity and data management capabilities, especially if your work involves extensive collaboration and task tracking.



Yo acabo de resolverlo acudiendo a la columna donde no se veía el contenido, nombre de columna> settings> format this column>advanced mode. Ahí eliminé todo el código JSON, sin más (dejando el marco vacio), y le dí al "save", y ahí se acabron mis problemas.


(La lista provenía de otra con formato personalizado, y, no sé cómo, esta columna "heredó" un código JSON que no funcionaba)

@PN3456789 I had the same issue, I clicked on '+ Add new item', clicked on the area shown in the red "circle" on my attached image, chose 'Edit columns' and say that the missing field was unticked. I just ticked the field and saved, and it appeared in all my views. Hope this helps.