SharePoint 2019 (On Premis) Fresh Install Problem - Event ID 6616

Copper Contributor

I have been trying for the last week to get a test/development environment set up for SharePoint 2019. I have followed microsoft's guides, youtube videos, block posts, etc, yet i continue to run into the same issue every time 


When install completes and i run the wizards to set up the farm and create the initial site collection, it all seems to go fine. I create the site and can navigate it, etc... however, every time i try to add an Access App to the site, i get "unexpected error". I look at the event viewer and find the following error:

I have tried everything from using Administrator as the service account to using a sing server for everything (Domain, DB and SP) and 3 separate servers for each part... still always run into this issue. I have tried Server 2019 and Server 2022. I have tried SQL Server 2022 which should work... 


I have verified the service account and admin accounts are in the WSS_WPG and WSS_ADMIN_WPG groups... no idea what is going on and nothing says what registry key is the one where access is being denied... 


especially doesn't make sense when i have it all set up to just use a single Administrator account.. 


   [ Name]Microsoft-SharePoint Products-SharePoint Foundation
   [ Guid]{6fb7e0cd-52e7-47dd-997a-241563931fc2}
   [ SystemTime]2023-10-16T15:01:53.953670500Z
   [ ActivityID]{ecb2e4a0-4693-d0d6-22de-69bd9db572de}
   [ ProcessID]952
   [ ThreadID]5288
   [ UserID]S-1-5-17
  string0Requested registry access is not allowed.



Correlation ID: ecb2e4a0-4693-d0d6-22de-69bd9db572de

Date and Time: 10/16/2023 11:01:53 AM

1 Reply
if anyone knows how to fix this... please. have tried different server OS and SQL combinations and always get this issue...