SharePoint 2019 On Prem - Open List Item Attachments in Client App

%3CLINGO-SUB%20id%3D%22lingo-sub-2605227%22%20slang%3D%22en-US%22%3ESharePoint%202019%20On%20Prem%20-%20Open%20List%20Item%20Attachments%20in%20Client%20App%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2605227%22%20slang%3D%22en-US%22%3E%3CP%3EWe%20implemented%20SharePoint%202019%20on%20prem%20and%20have%20sites%20with%20lists%20that%20contain%20item%20attachments.%20We%20have%20already%20changed%20Site%20Collection%20and%20list%2Flibrary%20settings%20to%20open%20the%20files%20in%20client%20app.%20That%20works%20for%20document%20libraries%20but%20not%20for%20list%20item%20attachments.%20Any%20ideas%3F%20currently%20the%20file%20downloads%20and%20the%20user%20edits%20but%20has%20to%20delete%2Freupload%20the%20document%20to%20save%20it%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-2605227%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAttachment%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EChrome%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ELists%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-2606740%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%202019%20On%20Prem%20-%20Open%20List%20Item%20Attachments%20in%20Client%20App%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-2606740%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F1119462%22%20target%3D%22_blank%22%3E%40kburckhart%3C%2FA%3E%26nbsp%3BWanted%20to%20also%20note%20that%20the%20issue%20is%20happening%20with%20Chrome%20and%20Edge%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

We implemented SharePoint 2019 on prem and have sites with lists that contain item attachments. We have already changed Site Collection and list/library settings to open the files in client app. That works for document libraries but not for list item attachments. Any ideas? currently the file downloads and the user edits but has to delete/reupload the document to save it

2 Replies

@kburckhart Wanted to also note that the issue is happening with Chrome and Edge

Hello @kburckhart have you install a oos server ? Office Online Server in your sharepoint 2019 farm ?

if not,  FYI you can go here https://docs.microsoft.com/fr-fr/officeonlineserver/office-online-server?WT.mc_id=M365-MVP-4039797 to understand how install an deploy it.

 

You can also set oos to not open file from link via https://docs.microsoft.com/en-us/powershell/module/officewebapps/set-officewebappsfarm?view=officewe...  and use : -OpenFromUrlEnabled