SharePoint 2019 + Anonymous Access + Microsoft Edge = CSP issues

%3CLINGO-SUB%20id%3D%22lingo-sub-1059130%22%20slang%3D%22en-US%22%3ESharePoint%202019%20%2B%20Anonymous%20Access%20%2B%20Microsoft%20Edge%20%3D%20CSP%20issues%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1059130%22%20slang%3D%22en-US%22%3E%3CP%3EI%20do%20not%20know%20if%20this%20also%20occurs%20for%20SharePoint%20Online%2C%20if%20someone%20can%20test%20this%20for%20me%2C%20I%20would%20appreciate%20it.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20accessing%20my%20SharePoint%202019%20site%20on%20Microsoft%20Edge%20as%20an%20anonymous%20user%2C%20I%20get%20paraded%20by%20a%20bunch%20of%20login%20dialogs%20asking%20for%20credentials.%20Every%20time%20a%20cancel%20is%20hit%2C%20it%20continues%20trying%20to%20load%20the%20page%20until%20the%20page%20is%20more%20or%20less%20finished%20loading.%20See%20below%20screenshot%20for%20a%20snippet%20of%20the%20logs%20appearing%20in%20DevTools.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20999px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F160999iCBE94199BAC354DF%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22clipboard_image_0.png%22%20title%3D%22clipboard_image_0.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThe%20anonymous%20users%20have%20the%20following%20permissions%3A%3C%2FP%3E%3CUL%3E%3CLI%3E%3CSPAN%3EView%20Items%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%3EView%20Pages%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%3EView%20Versions%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%3EView%20Application%20Pages%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%3EUse%20Client%20Integration%20Features%3C%2FSPAN%3E%3C%2FLI%3E%3CLI%3E%3CSPAN%3EOpen%3C%2FSPAN%3E%3C%2FLI%3E%3C%2FUL%3E%3CP%3EThis%20works%20on%20all%20other%20browsers%20(including%20ironically%20Internet%20Explorer).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDoes%20anyone%20know%20how%20to%20resolve%20this%20issue%3F%20Is%20there%20a%20web.config%2C%20or%20permission%20setting%20that%20I%20am%20missing%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3ERegards%2C%3C%2FP%3E%3CP%3EAS.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1059130%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Edge%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%202019%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Occasional Contributor

I do not know if this also occurs for SharePoint Online, if someone can test this for me, I would appreciate it.

 

When accessing my SharePoint 2019 site on Microsoft Edge as an anonymous user, I get paraded by a bunch of login dialogs asking for credentials. Every time a cancel is hit, it continues trying to load the page until the page is more or less finished loading. See below screenshot for a snippet of the logs appearing in DevTools.

 

clipboard_image_0.png

 

The anonymous users have the following permissions:

  • View Items
  • View Pages
  • View Versions
  • View Application Pages
  • Use Client Integration Features
  • Open

This works on all other browsers (including ironically Internet Explorer).

 

Does anyone know how to resolve this issue? Is there a web.config, or permission setting that I am missing?

 

Regards,

AS.

0 Replies