SharePoint 2016 on Prem - sync framework runtime 1.0 sp1 dependency

%3CLINGO-SUB%20id%3D%22lingo-sub-784343%22%20slang%3D%22en-US%22%3ESharePoint%202016%20on%20Prem%20-%20sync%20framework%20runtime%201.0%20sp1%20dependency%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-784343%22%20slang%3D%22en-US%22%3EHi%20All%2C%20we%20have%20On%20Prem%20SharePoint%202016%20topology%20in%20our%20application%20infra.%20For%20SharePoint%20sync%20framework%20runtime%201.0%20sp1%20is%20one%20of%20the%20pre%20requisites%20and%20gets%20installed%20as%20part%20of%20SharePoint%20setup.%20Microsoft%20has%20discontinued%20the%20support%20for%20sync%20framework%20runtime%201.0%20sp1.%20With%20this%2C%20our%20security%20team%20raised%20concern%20of%20using%20non%20supported%20framework%20asking%20us%20to%20upgrade%20to%20sync%20framework%202.x.%3CBR%20%2F%3EIs%20SharePoint%202016%20support%20sync%20framework%20runtime%202.x%3F%3CBR%20%2F%3EPlease%20help%20get%20this%20answered.%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-784343%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3ESharePoint%202016%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-784412%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%202016%20on%20Prem%20-%20sync%20framework%20runtime%201.0%20sp1%20dependency%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-784412%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F385878%22%20target%3D%22_blank%22%3E%40SriniAcn%3C%2FA%3E%26nbsp%3BThe%20sync%20framework%20installed%20is%20fully%20supported%20for%20the%20SharePoint%20product%20lifecycle.%20The%20info%20is%20located%20at%26nbsp%3B%3CA%20href%3D%22https%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Finstall%2Fhardware-and-software-requirements%23software-requirements-for-sharepoint-server-2016%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%22%3Ehttps%3A%2F%2Fdocs.microsoft.com%2Fen-us%2Fsharepoint%2Finstall%2Fhardware-and-software-requirements%23software-requirements-for-sharepoint-server-2016%3C%2FA%3E.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3EYou%20cannot%20upgrade%20the%20Sync%20framework.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Occasional Visitor
Hi All, we have On Prem SharePoint 2016 topology in our application infra. For SharePoint sync framework runtime 1.0 sp1 is one of the pre requisites and gets installed as part of SharePoint setup. Microsoft has discontinued the support for sync framework runtime 1.0 sp1. With this, our security team raised concern of using non supported framework asking us to upgrade to sync framework 2.x.
Is SharePoint 2016 support sync framework runtime 2.x?
Please help get this answered.
1 Reply

@SriniAcn The sync framework installed is fully supported for the SharePoint product lifecycle. The info is located at https://docs.microsoft.com/en-us/sharepoint/install/hardware-and-software-requirements#software-requ....

 

You cannot upgrade the Sync framework.