SharePoint 2016 @ Imcompatibilities with Internet Explorer (document mode=11)

%3CLINGO-SUB%20id%3D%22lingo-sub-325593%22%20slang%3D%22en-US%22%3ESharePoint%202016%20%40%20Imcompatibilities%20with%20Internet%20Explorer%20(document%20mode%3D11)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325593%22%20slang%3D%22en-US%22%3E%3CP%3E%3CBR%20%2F%3EHi%20everyone.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHe%20have%20recently%20migrated%20our%20SharePoint%20from%202013%20to%202016.%3C%2FP%3E%3CP%3EDue%20to%20group%20politics%2C%20right%20now%20the%20Internet%20Explorer%2011%20document's%20mode%20is%20being%20forced%20to%20be%20%3D%2011%2FEdge.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EAt%20the%20moment%20we%20have%20found%202%20%22incompatibility%22%20issues%20on%20the%20document%20libray%3A%3C%2FP%3E%3CP%3E1%20-%20The%20%22Open%20with%20Explorer%22%20feature%2Fbutton%20is%20grayed%20out%2Fdisabled%3B%3C%2FP%3E%3CP%3E2%20-%20When%20clicking%20to%20open%20a%20pdf%2C%20the%20file%20will%20be%20opened%20in%20the%20current%20tab%20but%20also%20in%20a%20new%20tab...%20while%20the%20expected%20behavior%20is%20to%20be%20open%20only%20in%20the%20new%20tab.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EBy%20changing%20the%20document%20mode%20from%2011%2FEdge%20to%2010%2C%20in%20the%20IE's%20emulation%20window%20(after%20pressing%20F12)%2C%20all%20of%20the%20previous%20mentioned%20issues%20are%20gone...%20but%20this%20is%20not%20a%20solution%20since%20we%20can't%20request%20the%20document's%20mode%20to%20be%20forced%20as%2010%20(due%20to%20group%20rules).%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EDid%20%2F%20Is%20anyone%20facing%20this%20problems%3F%20If%20yes%2C%20what%20have%20you%20done%20to%20solve%20it%3F%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20in%20advance!%3C%2FP%3E%3CP%3EKind%20regards.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-325593%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EInternet%20Explorer%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-325645%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%202016%20%40%20Imcompatibilities%20with%20Internet%20Explorer%20(document%20mode%3D11)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-325645%22%20slang%3D%22en-US%22%3EHi!%20It%E2%80%99s%20a%20double%20feature%20to%20open%20this%20once%20in%20new%20tab%20and%20next%20time%20in%20same%20page%3F%20Pls%20check%20the%20library%20settings%20-Advanced%3A%20du%20you%20have%20Folders%3F%20Where%20is%20your%20pdf%20to%20open%3F%20Is%20it%20saved%20in%20a%20folder%3F%20Folders%20are%20sometimes%20not%20visible%20in%20modern%20views.%20Next%20question%3A%20maybe%20your%20pdf%20admin%20is%20a%20link%2C%20you%20can%20see%20it%20on%20the%20library%20page%20(edit%20page)%3A%20go%20to%20the%20link%20tab%20in%20the%20ribbon%20above.%20Maybe%20your%20pdf%20folder%20is%20also%20linked%20with%20option%20%E2%80%9E%20show%20it%20in%20new%20page%E2%80%9C%20(classic%20layout)%20.%20I%20suggest%20your%20admin%20should%20go%20to%20central%20administration%20and%20in%20%E2%80%9Esettings%E2%80%9C%20there%20it%20can%20be%20centrally%20changed%20to%20%E2%80%9Emodern%20experience%E2%80%9C.%20Hope%20that%20helps%2C%20Greets%20from%20Eva%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-615296%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%202016%20%40%20Imcompatibilities%20with%20Internet%20Explorer%20(document%20mode%3D11)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-615296%22%20slang%3D%22en-US%22%3EHi%20we%20have%20the%20same%20Problem%20with%20the%20%22Open%20in%20Explorer%22.%20Did%20you%20find%20a%20solution%20meanwhile%3F%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-615706%22%20slang%3D%22en-US%22%3ERe%3A%20SharePoint%202016%20%40%20Imcompatibilities%20with%20Internet%20Explorer%20(document%20mode%3D11)%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-615706%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F271991%22%20target%3D%22_blank%22%3E%40Duarte_Sousa11%3C%2FA%3E%26nbsp%3B%3C%2FP%3E%3CP%3EIt%20is%20documented%20that%20Open%20with%20Explorer%20is%20not%20compatible%20with%20Edge%20(or%20Chrome%2C%20for%20that%20matter).%26nbsp%3B%20As%20for%20the%20PDF's%20opening%20in%20a%20second%20tab%2C%20have%20never%20had%20that%20issue.%3C%2FP%3E%3C%2FLINGO-BODY%3E
Highlighted
Occasional Visitor


Hi everyone.

 

He have recently migrated our SharePoint from 2013 to 2016.

Due to group politics, right now the Internet Explorer 11 document's mode is being forced to be = 11/Edge.

 

At the moment we have found 2 "incompatibility" issues on the document libray:

1 - The "Open with Explorer" feature/button is grayed out/disabled;

2 - When clicking to open a pdf, the file will be opened in the current tab but also in a new tab... while the expected behavior is to be open only in the new tab.

 

By changing the document mode from 11/Edge to 10, in the IE's emulation window (after pressing F12), all of the previous mentioned issues are gone... but this is not a solution since we can't request the document's mode to be forced as 10 (due to group rules).

 

Did / Is anyone facing this problems? If yes, what have you done to solve it?

 

Thanks in advance!

Kind regards.

3 Replies
Highlighted
Hi! It’s a double feature to open this once in new tab and next time in same page? Pls check the library settings -Advanced: du you have Folders? Where is your pdf to open? Is it saved in a folder? Folders are sometimes not visible in modern views. Next question: maybe your pdf admin is a link, you can see it on the library page (edit page): go to the link tab in the ribbon above. Maybe your pdf folder is also linked with option „ show it in new page“ (classic layout) . I suggest your admin should go to central administration and in „settings“ there it can be centrally changed to „modern experience“. Hope that helps, Greets from Eva
Highlighted
Hi we have the same Problem with the "Open in Explorer". Did you find a solution meanwhile?
Highlighted

@Duarte_Sousa11 

It is documented that Open with Explorer is not compatible with Edge (or Chrome, for that matter).  As for the PDF's opening in a second tab, have never had that issue.