SharePoint 2013 workflow option disappeard from SP designer

New Contributor


I have configured workflow manager on our SharePoint 2016 environment. It was working fine. We installed SharePoint patch and ran the product configuration wizard, after running it the SharePoint 2013 workflow options disappeared from SP designer. I am asking is it out of the box behavior or  we have some incorrect configuration with Workflow manager. 



6 Replies



It definitely sounds like an issue with the Workflow Manager configuration or services.  Workflow Mgr is generally separate from SharePoint, but other things could have thrown it off.  There are a few things to check:


  1. In Central Admin -> Service Apps, do you see the Workflow service Proxy listed and when clicked, it shows connected?
  2. What is the status of all the workflow services?  Service Bus Broker, Workflow Service backend, etc.  
  3. Are you using self-signed certs (via WF mgr config) or like a wildcard?  Be sure the cert isn't expired (I doubt this is the case).
  4. Is this a single server farm or multi?  On the server with the Workflow Manager installed, check the Workflow Mgr event logs to see if you see any errors.
  5. Check the health of the WF farm with some PowerShell using like Get-WFFarm and Get-WFFarmStatus.  Follow these steps.

Worst case you might try to re-run the Register-SPWorkflowService command to re-establish a connection between SharePoint and the workflow manager.  Hopefully one of these checks will reveal the culprit and lead you to a solution.  Post any feedback and we can try to point you in a more precise direction.  


@Doug Allen Thank you so much for your response. 

Following is my response for each query:


1. Yes. Workflow Service Proxy is listed and shows connected

2. All of these services services are running on the workflow configured server.

3.  We are using Self-signed certificate. Expiry date is 22/11/2023

4. It is multi-server farm. (2=Front end server, 2= Search Servers, 2= Application Servers, 2 = Distributed cache servers), i have configured the workflow on one of the distributed cache server. Do you think it could be a problem installing it on the distributed cache server?

5.  All the services are running on the farm, following is the example:


Furthermore, Checked event logs Found only one error with Event id 564
Best Response confirmed by Zulfi11 (New Contributor)



Sounds like everything is in good shape.  I would try to re-register the workflow service with SharePoint and see if that takes care of it.  Do you the patch level of the WF farm like CU2,3,4 or 5?  You don't have TLS 1.2 enabled in your environment do you?    

i tried to re-register and also installed workflow manager client on both front end servers, which fixed the issue.

@Zulfi11 Since nothing else was wrong I figured that would do it.  Glad that worked for you.  You do only need to do it once though.