SharePoint 2013 - Web Application is Not accessible - Getting Strange Issue


Dear Team, 


We got a strange PROD issue like one of our web application is not accessible. All the site collections underneath also is not accessible. Any help is appreciated. Please check the screenshot of the error we get once we try to access the site collections.


> While Accessing the Site Collection




> The above one is for while accessing the Web Application root site 


Troubleshooting steps done so far. But no luck 

1. Checked the state of the web app using powershell- its online.

2. Under view all site collections - all the site collections are present. Able to retrieve those info in powershell as well.

3. Able to create new site collections under the web app but while accessing the site, getting the same error. 

4. DB is fine too. Tried creating a test table in the DB and verified.

5. No site collections are deleted.

6. While accessing the web app alone in the browser getting the HTTP Error 500. But while accessing  the  site collection getting the HTTP/1.1 200 Ok error. But no sites are accessible.

7. Rest of the web applications are working perfectly fine in the farm.

8. No proper error details in the event viewer and ULS Logs.


Any help is appreciated...

5 Replies
Do you have multiple databases with the same site(s) attached? If the databases are attached, DNS, IIS bindings, AAMs are all correct, this is often when someone has attached the same database (or two databases containing the same site ID) in a single farm.
Hi Trevor,

Here is how the web app is DB architecture

> Web App -
>Site Collection 1 - Content DB A
>Sitecollection 2 - Content DB B
>Site Collection 3 - Content DB A
> Site Collection 4 - Content DB C

I’ll send you the screenshot shortly. Same site is not attached to multiple Content DB. Site bindings and AAM are fine

The Issue is RESOLVED by the below steps which i have found My-self. No Blogs helped me!


Hope this response will help a lot of crowd in future.


Steps in Brief:


1. Since everything is fine from DB end, Server End, Application Pool End and also all other web application are working fine too. Had a gut feeling that there could be something wrong with the Service Account.

2. Went to Configure Service Accounts in CASAIssue.PNG

4. Check the service account used by Web Apps which are up and running and check for the one which is down.

5. After identifying the ODD Service Account.

6. Go to  > iis Manager > Right click on the Application Pool of the Web App which is down under Application Pools > click on Advanced Settings > Under Identity > change the service account to the one which is working fine. > Click on OK > Refresh Application Pool and Restart the Web App. 




The Web Application started running!!


Saved 1000 Users!


Sharing is Caring!!



Keep in mind that the change you made will NOT persist. It will not replicate to other servers nor will it change if you do anything that re-provisions the Web Application.


You should consolidate your Web Applications to a single IIS Application Pool (same with Service Applications, sans PowerPivot Conversion Service, if applicable).

Now the Web App is up and running without any issues. Let’s see how long it will persist in the current state. This thread will be open for more discussions with this context.