SharePoint 2013 install fails with error 1603 cannot be done'!!!'m%20curious%2C%20why%20d't%20go%20straight%20from%202010%20to%202019.%20So%20here%20we%20are%20%3A)'s%20my%20life.%20not%20t*with*%20SP1%20ISO%20you've%20downloaded%20from%20MSFT%3F%20Slipstreaming%20yourself%20won't%2's%20comment%20is%20correct.%20This%20doesn't%20work%20with%20slipstreamed%20service%20packs%2C%20you%20need%20to%20download%20the%20SP2013%20install%20with%20SP1%20included.%3C%2FP%3E%0A%3CP%3E%26nbsp%3B%3C%2FP%3E%0A%3CP%3ESorry%20for%20the%20slow%20reply%2C%20I'm%20in%20New%20Zealand%20so%20I've%20been%20sleeping%20while%20you're%20working%20%3A)'s%20own.%20BUT%2C%20the%20install%20worked%20when%20i%20replaced%20this%20whole%20%22global%22%20directory.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%3ENew%20MSI%20was%20created%20on%202.10.2012%20and%20the%20one%20i%20had%20was%20newer%20-%20created%20on%2025.01.2014.%3C%2FSPAN%3E%3C%2FP%3E%3CP%3E%3CSPAN%3EFor%20some%20reason%20the%20installation%26nbsp%3'll%20add%20a%20link%20to%20this%20on%20my%2't%20a%20good%20ide
Occasional Contributor

My challenge is to install SharePoint 2013 SP1 server on Windows 2012R2 Server with SQL Server 2014 as the database. All on one server.


All of my attempts have so far failed to get over the installation error 1603 from the Microsoft Installer Bootstarapper. Someone please help.


I checked all the websites out there in hope of finding the issues and get this installation competed but nothing helps. HELP.

19 Replies

@aselimagic I had exactly the same problem and a few others related to the same type of install. Here's my notes and solution


I hope this helps




Hi Steve. Thanks for the hint. It shows installed for me. So when running the pre-reqs it says AppFabric is already there, with nothing to do. But, worth a shot, i will uninstall it, then try the command line install.

Hi Steve @Steve Knutson,


Failed again. I uninstalled the AppFabric, also the 1.1 updated. Then installed using the command line like you did. It installed without issue again.


BUT SharePoint 2013 SP1 installation again failed and rolled back everything. How frustrating!!!

I'm curious, why do you want to install software that is no longer supported by MS?

@Steve Knutson 


digging through my logs i see the 1603 attached to this MSI. Then it rolls back the whole chain. 


Error: Failed to install product: C:\SharePoint\Install\SharePoint2013\global\oserver.MSI ErrorCode: 1603(0x643).

Hi there @Dean Gross 


We need to migrate up to 2019 - but can't go straight from 2010 to 2019. So here we are :)

UGGH, you have my sympathy :)
I would recommend keeping the SQL and SP on separate machines to help upgrade performance.

@Dean Gross 

yeah that's my life. not to say i needed an installation error at the very beginning...

SharePoint 2013 SP1 and SQL 2014 are fully supported.

Are you using a SharePoint 2013 *with* SP1 ISO you've downloaded from MSFT? Slipstreaming yourself won't work.

Also, 1603 is a generic MSI error. You need to add voicwarmupx to get more details from the MSI logs which will be in %TMP% -

@aselimagic I checked my install notes and Trevor's comment is correct. This doesn't work with slipstreamed service packs, you need to download the SP2013 install with SP1 included.


Sorry for the slow reply, I'm in New Zealand so I've been sleeping while you're working :)

Not an issue. Did download the SP2013 w SP1 from MSFT.

So the next good suggestion you have is trying to get to the bottom of the 1603 message on the MSI. And hopefully it reveals how to solve it.
Hehe thanks anyways for chiming in. Now you get to work and we rest :)

The installation really should not make this much trouble - can’t even imagine the config and migration steps that are to follow.

@Trevor Seward @Steve Knutson 


So i added the registry entry for Installer logging - but nothing new is logged?

I do see some older logs there and one of them says for my troublesome MSI - oserver.msi is incompatible


Then i tried to set the compatibility and only option is - Compatible with previous Windows versions - none to be selected. What? But then installation fails anyways with the same error.


I saw this article but not sure if this is the right way forward and how safe can it be:

best response confirmed by aselimagic (Occasional Contributor)

@Trevor Seward @Steve Knutson 


Finally solved this problem. It appears the MSI - oserver.msi was having an issue with compatibility (i assume windows). I downloaded another copy of SharePoint SP1 from MSDN and copied the oserver.MSI package into my initial installation (extracted ISO). I tried just the new copy of the install from MSDN that failed, and the old one also failed on it's own. BUT, the install worked when i replaced this whole "global" directory.


New MSI was created on 2.10.2012 and the one i had was newer - created on 25.01.2014.

For some reason the installation did not like this newer version of the oserver.MSI

Thank you to both @Trevor Seward @Steve Knutson - each of you helped in a way to get to the logs of the MSI and also to check the AppFabric install. It seems the AppFabric was not culprit this time around.

@aselimagic I'll add a link to this on my blog. Glad you got to the bottom of the issue. Well done.

could u please send me link for msdn source u downloaded cause i get same issue
MSDN is a pay-for service. You need to purchase a subscription. Mix and matching MSIs isn't a good idea. SP 2013 w/ SP1 ISO works on Win Svr 2012 R2 without issues.
Download direct from MSDN. Then just compare the versions of oserver.MSI
As you can see above - older MSI was created on 2.10.2012 and the one I had was newer - created on 25.01.2014. If you have the new one, try replacing it with the older msi version.