Set-SPOSite Conditional Access Error (AuthContextStrength)

New Contributor



We have set AllowLimitedAccess for quite some time to our sites with the same command:


Set-SPOSite -Identity IdentityHere -ConditionalAccess AllowLimitedAccess 


Until today, when it suddenly threw an error : Set-SPOSite : Field or property "AuthContextStrength" does not exist.



Tried on couple of other test tenants but still the same issue. The problem is also not for a specific site but for all sites.


Any suggestions would be much appreciated



23 Replies



I have the same problems with PnP.PowerShell (Powershell Core) since today (yesterday everything worked).


PS: The old (deprecated) SharePointPnPPowerShellOnline module works.




I am getting the same error on my tenant for PnP.PowerShell (Powershell Core) 




Seems like something broke on the Microsoft side



no it has not been fixed yet. 

Same here:

Get-PnPTenantSite : The property or field 'AuthContextStrength' has not been initialized. It has not been requested or the request has not been executed. It may need to be explicitly

Wait for the new nightly release and try again.
Is there a workaround for this other than PnP Core upgrade?
Same here, everything used to work up until Monday, Tuesday suddenly it stopped.

@IM That only fixes it for people who are using PnP.PowerShell. Does anyone know what we can do about the standard SharePoint Management PowerShell?

Set-SPOSite : Field or property "AuthContextStrength" does not exist.
At line:1 char:1


@Osh_A415 we are currently investigating this behavior

Set-SPOSite : Field or property "AuthContextStrength" does not exist.
At line:1 char:1


Thank you, Do you have any updates on this issues ? I had run share point power shell this morning ang getting same error ? @Bruno Aleixo 

Looks like you can pass a Site object to Set-SPOTenant like this
get-sposite https://domain.tld/site/ | set-spotenant -ConditionalAccessPolicy AllowLimitedAccess
Tested it and successfully changed the ConditionalAccessPolicy for that site. (Not the Tenant)



I resolved by updating the Powershell ISE to use a new version of Powershell as well as updating the

PnP.PowerShell to use a newer build.  I installed Visual Studio Code, added the Powershell Extension, then ran the following command to install a new release of PNP.Powershell
Install-Module -Name PnP.PowerShell -AllowPrerelease
Any updates on this? I haven't seen any updates to the SharePoint Online PowerShell module, only the PnP module.

Nevermind, I see the update in the message center now :)


Current status: Following our internal testing and validation, we've deployed our code fix to the affected environments. We're monitoring the fix deployment as it is safely implemented through our change management process, and are expecting for it to have remediated impact by Monday, August 23, 2021.