Search results wont open in client app SP2019

%3CLINGO-SUB%20id%3D%22lingo-sub-1861326%22%20slang%3D%22en-US%22%3ESearch%20results%20wont%20open%20in%20client%20app%20SP2019%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1861326%22%20slang%3D%22en-US%22%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EI%20have%20issue%20I%20cant%20seem%20to%20solve%20at%20the%20moment%3A%20all%20search%20results%20(and%20this%20includes%20items%20returned%20in%20the%20%22Highlighted%20Content%22%20web%20part)%20don't%20seem%20to%20want%20to%20open%20with%20the%20client%20application.%20So%2C%20if%20a%20bunch%20of%20docx%20files%20are%20returned%20in%20a%20search%2C%20clicking%20on%20a%20file%20will%20result%20in%20downloading%20a%20copy%20%2F%20showing%20the%20save%20prompt.%20Libraries%20are%20all%20sorted%20for%20opening%20in%20the%20client%20application%2C%20if%20I%20open%20a%20file%20directly%20from%20a%20library%20it%20opens%20up%20to%20edit%20in%20the%20client%20app.%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EI%20have%20tried%20a%20few%20things%20such%20as%20returning%20to%20the%20classic%20experience%20and%20editing%20the%20search%20preferences%20to%20open%20in%20client%20application%20(which%20doesn't%20change%20anything%20in%20classic%20or%20modern%20experience).%20I%20have%20also%20changed%20the%20settings%20in%20Central%20Admin%20of%20the%20Browser%20File%20Handling%20to%20Permissive%20-%20no%20impact.%20The%20feature%20to%20open%20in%20Client%20App%20is%20active%20and%20all%20libraries%20are%20set%20to%20open%20in%20client%20app.%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3E%26nbsp%3B%3C%2FP%3E%3CP%20class%3D%22_1qeIAgB0cPwnLhDF9XSiJM%22%3EAnyone%20else%20encountered%20this%2C%20or%20have%20any%20ideas%3F!%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1861326%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3E2019%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EFiles%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESearch%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Server%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
New Contributor

I have issue I cant seem to solve at the moment: all search results (and this includes items returned in the "Highlighted Content" web part) don't seem to want to open with the client application. So, if a bunch of docx files are returned in a search, clicking on a file will result in downloading a copy / showing the save prompt. Libraries are all sorted for opening in the client application, if I open a file directly from a library it opens up to edit in the client app.

 

I have tried a few things such as returning to the classic experience and editing the search preferences to open in client application (which doesn't change anything in classic or modern experience). I have also changed the settings in Central Admin of the Browser File Handling to Permissive - no impact. The feature to open in Client App is active and all libraries are set to open in client app.

 

Anyone else encountered this, or have any ideas?!

0 Replies