Request Approval Failed when approving access requests as Site Collection Admin or Site Owner

%3CLINGO-SUB%20id%3D%22lingo-sub-1387890%22%20slang%3D%22en-US%22%3ERequest%20Approval%20Failed%20when%20approving%20access%20requests%20as%20Site%20Collection%20Admin%20or%20Site%20Owner%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1387890%22%20slang%3D%22en-US%22%3E%3CP%3EIssue%20was%20first%20found%20by%20site%20owners%20but%20was%20recreated%20using%20a%20site%20collection%20admin%20account.%20Issue%20occurs%20on%20a%20subsite%20in%20a%20site%20collection%20using%20the%20team%20site%20template.%20Site%20group%20setup%20was%20set%20to%20default%20visitors%2C%20members%20and%20owners%20groups.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EPermissions%20are%20assigned%20to%20the%20file%20but%20user%20is%20not%20removed%20from%20access%20requests%20list%20and%20no%20notification%20of%20access%20assignment%20is%20sent.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EI've%20seen%20posts%20where%20this%20happens%20to%20site%20owners%20that%20have%20improper%20access%20to%20the%20file%20or%20the%20access%20request%20list%20but%20I%20have%20ensured%20full%20permissions%20for%20site%20owners%20across%20the%20board%20on%20the%20site%20and%20besides%20that%20can%20re-create%20with%20a%20site%20collection%20admin%20account.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHas%20anyone%20ever%20seen%20this%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1387890%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EPermissions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESecurity%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E
Highlighted
Frequent Visitor

Issue was first found by site owners but was recreated using a site collection admin account. Issue occurs on a subsite in a site collection using the team site template. Site group setup was set to default visitors, members and owners groups.

 

Permissions are assigned to the file but user is not removed from access requests list and no notification of access assignment is sent.

 

I've seen posts where this happens to site owners that have improper access to the file or the access request list but I have ensured full permissions for site owners across the board on the site and besides that can re-create with a site collection admin account.

 

Has anyone ever seen this?

0 Replies