Radiobutton value missing after submission

%3CLINGO-SUB%20id%3D%22lingo-sub-1848633%22%20slang%3D%22en-US%22%3ERadiobutton%20value%20missing%20after%20submission%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1848633%22%20slang%3D%22en-US%22%3E%3CP%3EThe%20radio%20buttons%20display%20my%20SharePoint%20list%20options%20as%20expected%2C%20they%20are%20selectable%20and%20save%20to%20the%20SharePoint%20list%20when%20a%20new%20item%20is%20added...but%20when%20you%20go%20to%20view%20that%20item%20or%20edit%20it%20in%20Sharepoint%2C%20the%20radio%20buttons%20do%20not%20display%20the%20selected%20choice%20from%20the%20list%3F%20Does%20anybody%20has%20a%20clue%20what%20is%20going%20on%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-1848633%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EMicrosoft%20Lists%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1848875%22%20slang%3D%22en-US%22%3ERe%3A%20Radiobutton%20value%20missing%20after%20submission%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1848875%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F855811%22%20target%3D%22_blank%22%3E%40Erikie%3C%2FA%3E%26nbsp%3BAre%20you%20using%20SharePoint%20default%20list%20form%20or%20customized%20form%3F%20Is%20it%20happening%20for%20only%20particular%20choice%20(radio)%20column%20or%20all%20choice%20columns%20in%20list%3F%3C%2FP%3E%3CP%3ECan%20you%20please%20try%20creating%20a%20new%20choice%20(radio)%20column%20in%20same%20list%20and%20see%20if%20it%20is%20causing%20problem%20for%20all%20choice%20columns%3F%3C%2FP%3E%3CHR%20%2F%3E%3CP%3EPlease%20click%20%3CSTRONG%3EMark%20as%20Best%20Response%3C%2FSTRONG%3E%20if%20my%20post%20helped%20you%20to%20solve%20your%20issue.%20This%20will%20help%20others%20to%20find%20the%20correct%20solution%20easily.%20It%20also%20closes%20the%20item.%20If%20the%20post%20was%20useful%20in%20other%20ways%2C%20please%20consider%20giving%20it%20%3CSTRONG%3ELike%3C%2FSTRONG%3E.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1848886%22%20slang%3D%22en-US%22%3ERe%3A%20Radiobutton%20value%20missing%20after%20submission%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1848886%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F373269%22%20target%3D%22_blank%22%3E%40ganeshsanap%3C%2FA%3E%26nbsp%3BThe%20radiobuttons%20are%20actually%20dropdown%20menu%20items%20created%20in%20Sharepoint%20and%20modified%20in%20Power%20Apps.%20All%20these%20modified%20radio%20buttons%20do%20exactly%20the%20same%2C%20you%20can%20submit%20your%20choice%2C%20these%20will%20show%20on%20the%20sharepoint%20list%2C%20you%20can%20edit%20in%20gridview.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EWhen%20i%20open%20an%20entry%2C%20these%20particular%20buttons%20do%20not%20show%20the%20selected%20value...I%20do%20have%20also%20dropdown%20menu%20items%20which%20do%20appear%20in%20the%20sharepoint%20after%20selection...%26nbsp%3B%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EThanks%20for%20your%20reply%2C%20regards%2C%20Erikie%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-1848915%22%20slang%3D%22en-US%22%3ERe%3A%20Radiobutton%20value%20missing%20after%20submission%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-1848915%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F855811%22%20target%3D%22_blank%22%3E%40Erikie%3C%2FA%3E%26nbsp%3BMaybe%20there%20is%20issue%20with%20saving%20radio%20button%20values%20from%20power%20apps%20customized%20form.%20What%20type%20of%20customization%20have%20you%20done%20using%20power%20apps%3F%3C%2FP%3E%3CP%3ECan%20you%20please%20share%20any%20screenshot%20or%20formulas%20you%20used%20for%20customization%3F%20It%20will%20help%20us%20to%20identify%20what%20is%20causing%20this%20issue.%3C%2FP%3E%3CHR%20%2F%3E%3CP%3EPlease%20click%20%3CSTRONG%3EMark%20as%20Best%20Response%3C%2FSTRONG%3E%20if%20my%20post%20helped%20you%20to%20solve%20your%20issue.%20This%20will%20help%20others%20to%20find%20the%20correct%20solution%20easily.%20It%20also%20closes%20the%20item.%20If%20the%20post%20was%20useful%20in%20other%20ways%2C%20please%20consider%20giving%20it%20%3CSTRONG%3ELike%3C%2FSTRONG%3E.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E
New Contributor

The radio buttons display my SharePoint list options as expected, they are selectable and save to the SharePoint list when a new item is added...but when you go to view that item or edit it in Sharepoint, the radio buttons do not display the selected choice from the list? Does anybody has a clue what is going on?

6 Replies

@Erikie Are you using SharePoint default list form or customized form? Is it happening for only particular choice (radio) column or all choice columns in list?

Can you please try creating a new choice (radio) column in same list and see if it is causing problem for all choice columns?


Please click Mark as Best Response if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

 

@ganeshsanap The radiobuttons are actually dropdown menu items created in Sharepoint and modified in Power Apps. All these modified radio buttons do exactly the same, you can submit your choice, these will show on the sharepoint list, you can edit in gridview.

 

When i open an entry, these particular buttons do not show the selected value...I do have also dropdown menu items which do appear in the sharepoint after selection... 

 

Thanks for your reply, regards, Erikie

@Erikie Maybe there is issue with saving radio button values from power apps customized form. What type of customization have you done using power apps?

Can you please share any screenshot or formulas you used for customization? It will help us to identify what is causing this issue.


Please click Mark as Best Response if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

 

@ganeshsanapSomewhere it does save something, but only visible and to be modified in grid view edit. Inlcuded an image with the formula from Item, which comes with the original dropdown menu items "L2" and "L3".

   

@Erikie Try setting Default property of Radio1 to:

 

Parent.Default

After this change, save the customized form and publish to SharePoint.

 


Please click Mark as Best Response if my post helped you to solve your issue. This will help others to find the correct solution easily. It also closes the item. If the post was useful in other ways, please consider giving it Like.

 

@ganeshsanap if this is the correct place (see image), than it does not work.....

 

If i look in the dropdown menu i see: DefaultSelectedItems set to Parent.Default. This item i do not have in the radio button. Can i create this myself?

 

in the end i set all back to dropdown menu's since the "DefaultSelectedItems" attribute is missing in the radiobutton.....too bad looked more fancy with the radiobuttons..

 

Regards, Erik