"Sharing failed: value cannot be null" when trying to share a site with an external user?

%3CLINGO-SUB%20id%3D%22lingo-sub-785448%22%20slang%3D%22en-US%22%3E%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20user%3F%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-785448%22%20slang%3D%22en-US%22%3E%3CP%3EWe're%20attempting%20to%20share%20one%20of%20our%20SharePoint%20sites%20with%20an%20external%20user%20and%20I'm%20currently%20just%20doing%20some%20testing%20with%20my%20own%20personal%20email%20address.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EEverything%20has%20been%20configured%20correctly%20in%20the%20Admin%20Center%20for%20external%20sharing%2C%20you%20can%20see%20the%20invite%20box%20is%20also%20confirming%20that%20the%20email%20address%20is%20outside%20our%20organisation.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3EHowever%2C%20whenever%20I%20hit%20the%20'share'%20button%20I%20receive%20the%20following%20error.%20It%20seems%20to%20happen%20in%20all%20browsers%20too.%20Does%20anyone%20know%20what%20this%20means%3F%20As%20far%20as%20I%20can%20tell%2C%20the%20email%20I%20have%20entered%20is%20not%20a%20null%20value.%3C%2FP%3E%3CP%3E%26nbsp%3B%3C%2FP%3E%3CP%3E%3CSPAN%20class%3D%22lia-inline-image-display-wrapper%20lia-image-align-inline%22%20style%3D%22width%3A%20840px%3B%22%3E%3CIMG%20src%3D%22https%3A%2F%2Fgxcuf89792.i.lithium.com%2Ft5%2Fimage%2Fserverpage%2Fimage-id%2F125383i98CA34BED7D73638%2Fimage-size%2Flarge%3Fv%3D1.0%26amp%3Bpx%3D999%22%20alt%3D%22sharing%20error.png%22%20title%3D%22sharing%20error.png%22%20%2F%3E%3C%2FSPAN%3E%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-LABS%20id%3D%22lingo-labs-785448%22%20slang%3D%22en-US%22%3E%3CLINGO-LABEL%3EAdmin%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3EPermissions%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESharePoint%20Online%3C%2FLINGO-LABEL%3E%3CLINGO-LABEL%3ESites%3C%2FLINGO-LABEL%3E%3C%2FLINGO-LABS%3E%3CLINGO-SUB%20id%3D%22lingo-sub-785570%22%20slang%3D%22en-US%22%3ERe%3A%20%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20us%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-785570%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F190211%22%20target%3D%22_blank%22%3E%40Toby%20McDaid%3C%2FA%3E%26nbsp%3Bhave%20you%20checked%20to%20made%20sure%20that%20the%20site%20collection%20is%20set%20to%20external%20sharing%3F%20You%20can%20have%20external%20turned%20on%20and%20still%20set%20a%20specific%20site%20to%20not%20share%20externally.%26nbsp%3B%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-785872%22%20slang%3D%22en-US%22%3ERe%3A%20%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20us%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-785872%22%20slang%3D%22en-US%22%3EYou%20could%20check%20that%2C%20but%20usually%20it%20wouldn't%20allow%20you%20to%20even%20put%20it%20in%20there%20and%20wouldn't%20check%20names%20properly.%20Have%20you%20tried%20another%20address%3F%20Maybe%20something%20specific%20to%20your%20account%20there%20and%20it%20being%20in%20the%20tenant%20or%20something%20already%20causing%20issue.%20Try%20sending%20to%20another%20address%20you%20may%20have%20that%20you%20haven't%20used%20before.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-787678%22%20slang%3D%22en-US%22%3ERe%3A%20%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20us%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-787678%22%20slang%3D%22en-US%22%3E%3CP%3E%3CA%20href%3D%22https%3A%2F%2Ftechcommunity.microsoft.com%2Ft5%2Fuser%2Fviewprofilepage%2Fuser-id%2F5976%22%20target%3D%22_blank%22%3E%40Berta%20K%3C%2FA%3E%26nbsp%3BThe%20site%20collections%20are%20definitely%20set%20up%20to%20allow%20sharing%2C%20they're%20on%20the%20'new%20and%20existing'%20option.%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-787686%22%20slang%3D%22en-US%22%3ERe%3A%20%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20us%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-787686%22%20slang%3D%22en-US%22%3EHi%20Chris%2C%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20done%20a%20number%20of%20tests%20now%2C%20trying%20it%20on%20two%20different%20site%20collections%20and%20using%20three%20different%20external%20email%20addresses.%20I%20even%20created%20a%20new%20email%20address%20with%20a%20random%20name%2C%20just%20in%20case%20the%20permissions%20were%20conflicting%20in%20some%20way%20to%20my%20Office%20365%20admin%20account%20which%20uses%20the%20same%20name.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-787851%22%20slang%3D%22en-US%22%3ERe%3A%20%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20us%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-787851%22%20slang%3D%22en-US%22%3E%3CP%3EDoes%20the%20account%20you%20are%20logged%20into%20SharePoint%20as%20(the%20one%20doing%20the%20inviting)%20have%20an%20email%20address%20%2F%20mailbox%3F%3C%2FP%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-787914%22%20slang%3D%22en-US%22%3ERe%3A%20%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20us%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-787914%22%20slang%3D%22en-US%22%3EHi%20Rob%2C%3CBR%20%2F%3E%3CBR%20%2F%3EI've%20just%20tried%20using%20a%20different%20O365%20account%20to%20my%20admin%20one%2C%20looks%20like%20the%20sharing%20is%20now%20working%20okay.%20However%2C%20the%20external%20email%20addresses%20I'm%20sharing%20with%20don't%20receive%20any%20email%20invitation%2C%20despite%20me%20ticking%20the%20'send%20email%20invite'%20option.%3CBR%20%2F%3E%3CBR%20%2F%3EEven%20if%20I%20use%20the%20external%20email%20address%20to%20try%20and%20access%20the%20site%20without%20accepting%20any%20kind%20of%20invite%2C%20Office%20365%20just%20says%20it%20doesn't%20recognize%20the%20account.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-787923%22%20slang%3D%22en-US%22%3ERe%3A%20%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20us%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-787923%22%20slang%3D%22en-US%22%3EFor%20the%20external%20email%20account%2C%20check%20the%20Junk%20%2F%20spam%20%2F%20etc%20-%20the%20automatic%20email%20sometimes%20ends%20up%20there.%3CBR%20%2F%3E%3CBR%20%2F%3EAlso%2C%20check%20in%20Azure%20AD%20to%20make%20sure%20the%20guest%20account%20has%20been%20invited%20-%20%3CA%20href%3D%22https%3A%2F%2Fportal.azure.com%2F%23blade%2FMicrosoft_AAD_IAM%2FUsersManagementMenuBlade%2FAllUsers%22%20target%3D%22_blank%22%20rel%3D%22nofollow%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fportal.azure.com%2F%23blade%2FMicrosoft_AAD_IAM%2FUsersManagementMenuBlade%2FAllUsers%3C%2FA%3E%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-788044%22%20slang%3D%22en-US%22%3ERe%3A%20%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20us%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-788044%22%20slang%3D%22en-US%22%3EDoesn't%20appear%20to%20be%20in%20any%20of%20the%20junk%20mailboxes.%20If%20the%20invite%20is%20valid%20and%20has%20been%20sent%2C%20would%20their%20name%20simply%20appear%20in%20the%20'all%20users'%20section%20of%20that%20link%20you%20posted%3F%20From%20what%20I%20can%20see%20none%20of%20the%20external%20emails%20I%20invited%20are%20showing%20in%20Azure.%3C%2FLINGO-BODY%3E%3CLINGO-SUB%20id%3D%22lingo-sub-788073%22%20slang%3D%22en-US%22%3ERe%3A%20%22Sharing%20failed%3A%20value%20cannot%20be%20null%22%20when%20trying%20to%20share%20a%20site%20with%20an%20external%20us%3C%2FLINGO-SUB%3E%3CLINGO-BODY%20id%3D%22lingo-body-788073%22%20slang%3D%22en-US%22%3EThe%20other%20place%20to%20check%20for%20guest%20users%20is%20%3CA%20href%3D%22https%3A%2F%2Fadmin.microsoft.com%2FAdminportal%2FHome%23%2FGuestUsers%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fadmin.microsoft.com%2FAdminportal%2FHome%23%2FGuestUsers%3C%2FA%3E%3CBR%20%2F%3E%3CBR%20%2F%3EIf%20they%20are%20not%20showing%20up%20at%20all%2C%20take%20a%20look%20at%20%3CA%20href%3D%22https%3A%2F%2Fprotection.office.com%2Funifiedauditlog%22%20target%3D%22_blank%22%20rel%3D%22noopener%20noreferrer%20noopener%20noreferrer%22%3Ehttps%3A%2F%2Fprotection.office.com%2Funifiedauditlog%3C%2FA%3E-%20filter%20on%20Activities%20'Shared%20file%2C%20folder%2C%20or%20site'%20-%20you%20should%20be%20able%20to%20see%20where%20you%20shared%20with%20the%20guest%20user.%3C%2FLINGO-BODY%3E
Highlighted
Contributor

We're attempting to share one of our SharePoint sites with an external user and I'm currently just doing some testing with my own personal email address.

 

Everything has been configured correctly in the Admin Center for external sharing, you can see the invite box is also confirming that the email address is outside our organisation.

 

However, whenever I hit the 'share' button I receive the following error. It seems to happen in all browsers too. Does anyone know what this means? As far as I can tell, the email I have entered is not a null value.

 

sharing error.png

9 Replies
Highlighted

@Toby McDaid have you checked to made sure that the site collection is set to external sharing? You can have external turned on and still set a specific site to not share externally. 

Highlighted
You could check that, but usually it wouldn't allow you to even put it in there and wouldn't check names properly. Have you tried another address? Maybe something specific to your account there and it being in the tenant or something already causing issue. Try sending to another address you may have that you haven't used before.
Highlighted

@Berta K The site collections are definitely set up to allow sharing, they're on the 'new and existing' option.

Highlighted
Hi Chris,

I've done a number of tests now, trying it on two different site collections and using three different external email addresses. I even created a new email address with a random name, just in case the permissions were conflicting in some way to my Office 365 admin account which uses the same name.
Highlighted

Does the account you are logged into SharePoint as (the one doing the inviting) have an email address / mailbox?

Highlighted
Hi Rob,

I've just tried using a different O365 account to my admin one, looks like the sharing is now working okay. However, the external email addresses I'm sharing with don't receive any email invitation, despite me ticking the 'send email invite' option.

Even if I use the external email address to try and access the site without accepting any kind of invite, Office 365 just says it doesn't recognize the account.
Highlighted
For the external email account, check the Junk / spam / etc - the automatic email sometimes ends up there.

Also, check in Azure AD to make sure the guest account has been invited - https://portal.azure.com/#blade/Microsoft_AAD_IAM/UsersManagementMenuBlade/AllUsers
Highlighted
Doesn't appear to be in any of the junk mailboxes. If the invite is valid and has been sent, would their name simply appear in the 'all users' section of that link you posted? From what I can see none of the external emails I invited are showing in Azure.
Highlighted
The other place to check for guest users is https://admin.microsoft.com/Adminportal/Home#/GuestUsers

If they are not showing up at all, take a look at https://protection.office.com/unifiedauditlog - filter on Activities 'Shared file, folder, or site' - you should be able to see where you shared with the guest user.