"Error:The file is locked" when using Office Online within SharePoint Online

Brass Contributor

At a current client I am seeing this scenario play out often:


1) User clicks on an Office document in a SPO document library, and it opens in a new tab in the associated Office Online app. They make an edit, the edit is auto-saved, and close the new tab. Or, they don't need to make any edits, just needed to view, so they close the tab.

2) In the original tab, they attempt to add metadata, or delete the file, but are told the file is locked. It then needs to time out before anyone can make edits to the file, and there doesn't appear to be any way to release the lock manually. 


The file would not be locked if the user refreshed the document library page after closing the additional tab, but this is not realistic to expect the user to know to do to avoid locks. 


I would like such documents to open in the same tab so the user would have to trigger a refresh when returning to the library. As far as I can tell this is not an option in settings - is this true? Is Microsoft aware of this bug? It is causing untold issues.


40 Replies

Bumping this because I would love to hear from anyone else experiencing this problem. We can't be the only one?

This happens to us as well in SPO. I've searched for a lot of solutions but, no. nothing that you could reply to a user of your site to say 'File is fixed'!


One solution offered was wait, 10 to 30 min. (try telling that to an annoyed user!!)
it works the odd time.

But i have had some cases last 24hrs before the lock finally went away. (even after a user restarted and went home for the day!)


 A menu item for admins to unlock 'short term' locks would be useful!



forgot to include this!:



seems like they had something for on-premise SP so there is a slim hope they have something similar for SPO


We've also been experiencing this problem more and more, where a users closes a document and then tries to move, rename or delete it and it says it's locked.


Presumably it thinks it's still open somewhere so it's being held in the browser memory, and the only way to fix it is to come back to it the next day! 


I have logged a service request with MS about this so they are looking in to it.

For what it's worth, Microsoft has acknowledged this was an issue and claims to have resolved it. In my preliminary tests, it does seem to be resolved. Fingers crossed it continues to be!




"This issue was posted to the Service Health Dashboard (SHD) as incident SP146930 starting at Aug 21 2018 3:52 PM (UTC). The user experience of this incident is : Users were unable to move or delete Microsoft Word documents.


Now, Service Health Dashboard has indicated that issue SP146930 has been resolved as of: Wednesday, August 22, 2018, at 3:26 PM UTC. If you are still experiencing an issue, please post a new thread on our forum."

I have seen this issue, albeit rarely, so I've never seen it as enough of an issue to raise it formally with Microsoft. The conditions under which I saw this was when a document was created in Word Online, i.e. someone just clicked New Word Document in a document library, and then tried to open it in Microsoft Word.


The lock persists for approx 10 minutes, so I usually advise my users that it's time for a coffee break and when they come back it's unlocked again. Not really a fix, just an observation from encountering the same issue.

It is not just you.  We have issues like this a couple of times a month.  Sometimes it happens when users are just updating the metadata properties and not the content of the file.  However, if the user has the file open in Word Online in one tab and the same user tries to edit the metadata of the same file in another tab, it reports the file is locked for editing by the same user.  If they close everything down and try again to edit metadata without opening in Word it will still give them lock error.  One way we have had success in releasing the locks is to have another user open the file using the Desktop version of Word and without doing anything but close again, the lock becomes freed, allowing the original user to edit the metadata.

We have the same issues and did not really find a way to release this lock. Sometimes user just have to wait more than several hours to release this document lock. We have tried to enable check-in and run check-out/check-in cycles on the locked document and sometimes this helps, sometimes the document just stays locked.

I made a service request to Microsoft about this issue and they seemed to have fixed it, at least for us!

Files are no longer getting locked, and if they do a simple refresh of the page fixes it straight away.
Also happening for us on occasion, seems to happen across multiple users on the same day and then resolves itself after a few days.

Definitely a wide issue and something Microsoft need to fix permanently!


Also having the same problem, issue for us is people would open a document to view the information and when they closed it the file would stay locked out to them.

Have found what appears to be a work around but may not fit everyone's needs if you want multiple people to amend at once.

If you have admin rights under Library Settings>Versioning Settings there is an option 'Require Check Out' that for us was defaulted to 'No'. I changed to 'Yes' and this then forces people to check out the document which then means people have to consciously select edit the workbook.

Yes, seems to be happening for us still @will_b .


No workaround for us seems to do the trick unfortunately.

@Andrew Silcock We have exactly the same issue and there does not seem to be a workaround, other than waiting for 30 minutes until the lock clears.  This is absolutely unacceptable from a support perspective, users are not going to live with that.

Bumping this to hopefully keep it alive. As a company that nearly exclusively uses SharePoint for document storage and collaboration, this is a very annoying issue.

@Chameleon_Queue_90 One of our in flight projects is SharePoint roll out, if this isn't fixed by the time we go live, it's probably going to be a show stopper.  Turning on force check out isn't an option as we have already had a lot of push back from the business over that......

We've seen this lock issue intermittently as well, and they usually release in 10-15 minutes, but sometimes it's longer. We're trying to keep track if the files have macros and/or if they're being synched to their OneDrive clients.
We have the same problem. I hope microsof's support will start to solve this problem and come up with a satisfactory solution. It is annoying to tell tenant users that the only possible way is to wait 10-15 minutes, or refresh the website.

I have had the same issue recently as myself locking the file. Although it was resolved by clicking back into the file in office web apps and instead of closing the tab I clicked the library name at the top of the page so the browser navigated away from the page which managed to unlock the file. It could be to do with how they have hooked the onunload event to the page and how this is supported in different browsers and for different scenarios.

ANy resolutions? I have run into the same issue, over a yer later :(

@barbaracummings No change, still experiencing the same issue.